Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Micro SD card cannot be formatted. 128GB


  • Please log in to reply
3 replies to this topic

#1 mingsrox

mingsrox

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:11 PM

Posted 10 July 2018 - 11:16 AM

I have tried diskpart command. Have 3 partitions, tried clean partition,delete partition, didnt work, tried format volume, stuck at 41% didnt go further for hours.

tried CHKSDK, the 3 partitions are  raw,raw and exfat type.

have tried the default formatting when pluck in usb driver.

 

Tried partition guru, after deleting partition the files and partition restored itself.

 

would be good if someone can help me.. thanks

 

 



BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:07:11 AM

Posted 11 July 2018 - 05:41 PM

My guess is you have a card that has gone bad, and it does happen.

 

See this help page from SanDisk:  https://kb.sandisk.com/app/answers/detail/a_id/14827/~/using-sd-formatter-tool-to-restore-full-capacity-on-sdhc%2Fsdxc-cards

 

I have used SD Card Formatter (link provided on the above noted page) successfully in the past.   I have also tried doing full formats using it, by intention, and having them fail - which pretty much tells you that the card is bad.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1809, Build 17763 

     Presenting the willfully ignorant with facts is the very definition of casting pearls before swine.

             ~ Brian Vogel

 

 

 

              

 


#3 JohnC_21

JohnC_21

  • Members
  • 24,657 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:11 AM

Posted 11 July 2018 - 06:48 PM

Tried partition guru, after deleting partition the files and partition restored itself.

 

That cannot happen unless the drive was write protected or you did not click Save All after doing the steps. But I think the SD card is bad as Brain said. 



#4 bles16

bles16

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Earth
  • Local time:07:11 AM

Posted 13 July 2018 - 08:31 PM

Hello!.
If the problem is not writing, try the steps again, one by one.
 
  • Win + R
  • Diskpart
  • list disk
  • select disk
  • details disk (see if it is possible to format)
  • clean
  • create partition primary
  • select partition 1
  • active
  • format fs=fat32 quick (for disk hdd; format fs=ntfs quick) 

They link that you have been provided is also your main manufacturer page.

 

To all successes.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users