Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

usb 3.0 can't connect with mouse or flashdrive but can connect to the phone


  • Please log in to reply
2 replies to this topic

#1 hammer2383

hammer2383

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 04 July 2018 - 02:48 PM

I have a problem with my laptop 

my laptop has 1 usb 2.0 port on the right side

2 usb 3.0 port on the left side

my only usb 2.0 port is damaged and can't be use

 

I tried to connect the 3.0 port with my wireless mouse and flash drive but none of that seem to work

 

but...it still deliver power and it work normally when I connected with my phone(Nokia 8)

 

I tried

-uninstall usb port driver 

-scan for change

 

this happened for a long time but I just didn't bother to fix it

**my laptop is ASUS A550V

please help!!

 

thank you and sorry for bad english

 

 



BC AdBot (Login to Remove)

 


#2 mightywiz

mightywiz

  • Members
  • 790 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:18 PM

Posted 05 July 2018 - 11:58 AM

yeah unfortunately some usb 3.0 ports are dedicated 3.0 only & won't work some devices like your mouse and keyboard dongles and some flash drives.

 

you might look at your bios settings and see if you can make changes to the usb ports.  that's where i'd start looking.

 

my pc at work has a crap load of usb ports and in the bios settings i can change parameters of how they are used.


Edited by mightywiz, 05 July 2018 - 12:01 PM.


#3 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:18 AM

Posted 05 July 2018 - 12:56 PM

Some BIOs allow you to set USB3 as USB2 but I'm not sure that is in your OEM UEFI firmware.

 

https://superuser.com/questions/480045/what-does-the-bios-setting-xhci-pre-boot-mode-do

 

USB 3.0 specs state that is has to be backward compatible with USB 2.0 but it doesn't always work as mightywiz posted. Personally, I have never ran into a USB 3.0 port that did not detect a USB 2.0 device. 


Edited by JohnC_21, 05 July 2018 - 01:00 PM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users