Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HDMI audio for TV not showing in sound\playback


  • Please log in to reply
No replies to this topic

#1 Raptor88

Raptor88

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:42 PM

Posted 28 June 2018 - 10:43 PM

Running Win10 on a Dell XPS8900 with a Nvidia GTX745 graphics card.
HDMI cable goes from (GTX745 card) > (4in x 2out monoprice switch) > (Samsung HDTV set).
I rt-click the speaker icon in the notification area, click "Sounds" and the Sound window opens. I click the "Playback" tab.

Scenario-1:
When the 4x2 switch is set to the Dell PC as the input and I boot the PC
, Win10 sees the Samsung TV and the Sound\Playback tab shows 3 playback devices:
... NVIDIA Output
... SAMSUNG
... Speakers \ Headphones
This is all good. I can select SAMSUNG as the default and I can hear audio from the PC on the Samsung TV set.

Scenario-2:
But if the 4x2 switch is NOT set to the PC as an input when I boot the PC
, Win10 does not list the Samsung TV set in Sound\Playback, which only shows 2 playback devices:
... NVIDIA Output
... Speakers \ Headphones

When I rt-click the playback pane, it displays the following two as being checked:
x Show disabled devices
x Show disconnected devices
So this is not the reason that the Samsung TV is not being shown.

Now without rebooting, if I set the 4x2 switch to the Dell PC as the input, Win10 sees the Samsung TV, the TV screen turns blue and I can move my VLC video player to the Samsung TV. Video displays on the TV but there is no sound.  Sound\playback does not show the Samsung TV.

So my question is: Is there a way to tell Win10 to register the Samsung TV's audio when I'm in Scenario-2 without having to do a restart?



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users