Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Monitor won't turn on after BIOS flashing.


  • Please log in to reply
2 replies to this topic

#1 Lucidolph

Lucidolph

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Local time:05:00 AM

Posted 24 June 2018 - 11:44 AM

Heyo
I built a PC
Motherboard: asrock ab350 pro4
CPU: Ryzen 3 2200g
I heard about the incompatibility issue, and you need a borrow a compatible Ryzen CPU to flash the BIOS, then you can use it normally.. Anyway I thought I'd give it a go to see if I'm lucky and it will just work without the hassle because it's happened for some.. The PC came on, so I flashed the BIOS via USB, I need to flash it twice, the bridge firmware, then the latest.. so I flashed the bridge firmware, all good.. THEN SUDDENLY The PC restarted, and now the monitor doesn't come on, it just flashes the screen light, as if it's on standby, no message, nothing.. I only have an HDMI monitor, I've tried the built in APU HDMI and the GPU socket.. I feel like I'm so close, and surely if it was INCOMPATIBLE like I was told, then it wouldn't of let me flash it the first time right? I have tried resetting the CMOS as it's a BIOS issue, but it did nothing? Gave it about 30seconds.. Anyone have any ideas?

 



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:00 AM

Posted 24 June 2018 - 05:16 PM

 

I thought I'd give it a go to see if I'm lucky . . .

 

The evidence suggests you weren't.

 

I can think of two things you could do. One is trying to flash the mobo back to its original BIOS. However, even if this worked you would still be left with the problem of a CPU which is not suitable for this mobo. The other is to write this mobo off to experience and buy one that is compatible with your Ryzen CPU.

 

Personally, if the manufacturers say that a given mobo and CPU are incompatible I would be inclined to take the statement at face value.

 

Chris Cosgrove



#3 Joe C

Joe C

  • Members
  • 922 posts
  • OFFLINE
  •  
  • Local time:05:00 AM

Posted 24 June 2018 - 10:47 PM

 

The PC came on, so I flashed the BIOS via USB,

Well if the pc booted in order for you to flash the bios, then you most likely  should not have flashed to the bridge bios before checking out what version you had to start with. I suspect now you probably need to use a Bristol Ridge cpu in order to get it to boot up and then finish updating to the newest bios (P4.60 or P4.70), because you now have that bridge bios (3.40)  which is not compatible with the Raven Ridge cpu.

AMD does provide a "boot kit" for you, find out here:

https://www.pcgamer.com/amd-will-lend-you-an-older-processor-to-update-your-bios-to-support-a-ryzen-apu/ 

 

Edit: This board does support the AMD Ryzen 3 2200G Raven Ridge cpu, starting with bios versions 4.40 and up

https://www.asrock.com/mb/AMD/AB350%20Pro4/#BIOS

 

Your board is probably o.k., its just that you installed an older bios that you can not use with the newer cpu


Edited by Joe C, 25 June 2018 - 07:46 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users