Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Connected but NO Internet Access!!


  • Please log in to reply
4 replies to this topic

#1 cooljay

cooljay

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:18 PM

Posted 23 June 2018 - 01:35 PM

This is something that has now been vexing me for days. I researched it online but the solutions that worked for people do not work in my case.

 

Here is the situation:

 

I don't have WifFi right now but need to go online with my laptop, so I created a hotspot with my iPhone and connected my laptop via USB. It worked a couple of times.

 

Because I didn't know that each time the question needs to be answered "Do you trust this computer?" I engaged in some unqualified trouble shooting and  I was in the process did something that suddenly only allowed me to get online through wifi. (I'm not crazy about a wifi connection because CPU and battery usage are enormous, and also, it's unnecessary. I can just use the USB cord.) But I wanted to get the ability to use USB again, but somehow, my phone now detected wifi and would only use that.

 

Again, I tried to fix this and again, I might have done something stupid by accident that is now causing access problems. Because suddenly, even though I was able to connect to my iPhone hotspot through wifi and the connection was as usual a solid 5 bars, there was no internet access.

 

I finally decided to abandon wifi altogether and get back to USB. I disabled the wifi adapters so that only the Apple device was now available. But the same thing: I am connected to the iPhone, but there no internet access.

 

I have a feeling that there is a brain-dead simple answer to this that someone who knows even just the basics of connectivity and access could see right away. But I'm not one of those people, and neither are any of the people I know.

 

I attached some screenshots.

The first one shows all the connections, the public wifi I'm on right now, the iphone, and an unidentified network that is always there. No idea why or what for. [attachment=205287:sharing center.png]

 

Second screenshot shows the connection status of the wifi I am currently using, and it strangely enough says No Internet Access. through Ipv4. I think that is because I am using a VPN.

[attachment=205288:wireless connection status through public wifi.png]

 

Third screenshot shows connection status through iphone. This is the first time that I see both of them side by side and even I can tell what's missing. The iphone lacks the SSID.

[attachment=205288:wireless connection status through public wifi.png]

 

Fourth shows the details of public wifi connection.

[attachment=205290:network connection details public wifi.png]

 

Fifth the details of iphone.

[attachment=205291:network connection details iPhone.png]

 

Is there anything here that you can see might be causing this inability to log on even though connected? Is it the lack of SSID in iphone? How can I add this? Or are the adapter settings all wrong? 

 

Thanks.


Edited by Chris Cosgrove, 23 June 2018 - 03:39 PM.
Moved from Win 7 to 'Networking'.


BC AdBot (Login to Remove)

 


#2 guit30

guit30

  • Members
  • 244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Abington, Pa.
  • Local time:01:18 PM

Posted 24 June 2018 - 09:54 PM

I was having same problem, then I tried restarting my laptop and it hooked up to internet, It Was a very frustrating problem. Reboot your router, make sure your cable to router is connected well at both ends.

 

 I just got a couple of updates from windows. Going to try installing them and see if they help my connection to internet better.

Jim

 

-try restarting computer!!!


Eset Nod32 vs 8

Super Anti Spyware

Secunia 2.0


#3 Replicator

Replicator

  • Members
  • 280 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dark Basement
  • Local time:04:18 AM

Posted 28 June 2018 - 08:07 AM

On the tethered iphone go to Settings > General > Reset, then tap Reset Network Settings.


The quieter you become, the more you are able to hear!
CEH, CISSP @ WhiteHat Computers Pty Ltd

 


#4 cooljay

cooljay
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:18 PM

Posted 08 July 2018 - 06:52 PM

Thanks for posting replies. Those were not the issues. I am still to some extent dealing with it.

 

It boils down to some DNS conflict. Repeatedly I get this in the event log:

 

Log Name:      System
Source:        Microsoft-Windows-DNS-Client
Date:          7/8/2018 5:04:04 PM
Event ID:      1014
Task Category: None
Level:         Warning
Keywords:      
User:          NETWORK SERVICE
Computer:      HP-Laptop
Description:
Name resolution for the name config.exceptionless.io timed out after

none of the configured DNS servers responded.

Event Xml:
<Event

xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-DNS-Client"

Guid="{1C95126E-7EEA-49A9-A3FE-A378B03DDB4D}" />
    <EventID>1014</EventID>
    <Version>0</Version>
    <Level>3</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2018-07-08T21:04:04.098245300Z" />
    <EventRecordID>354435</EventRecordID>
    <Correlation />
    <Execution ProcessID="1216" ThreadID="7180" />
    <Channel>System</Channel>
    <Computer>HP-Laptop</Computer>
    <Security UserID="S-1-5-20" />
  </System>
  <EventData>
    <Data Name="QueryName">config.exceptionless.io</Data>
    <Data Name="AddressLength">16</Data>
    <Data

Name="Address">020000350A0000010000000000000000</Data>
  </EventData>
</Event>

 

What are those weird names? exceptionless.io?

 

There is some kind of miscommunication or misdirection, but I don't have a clue how to fix this. I did sfc /scannow multiple times and nothing ever seems amiss.

 

If I log into the router, what would I be looking for?



#5 Replicator

Replicator

  • Members
  • 280 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dark Basement
  • Local time:04:18 AM

Posted 10 July 2018 - 09:52 AM

Windows grants or denies access and privileges to resources based on access control lists (ACLs), which use SIDs to uniquely identify users and their group memberships.

 

 

When a user logs into a computer, an access token  is generated that contains user and group SIDs and user privilege level.

When a user requests access to a resource, the access token is checked against the ACL to permit or deny particular action on a particular object.

Edited by Replicator, 10 July 2018 - 09:54 AM.

The quieter you become, the more you are able to hear!
CEH, CISSP @ WhiteHat Computers Pty Ltd

 





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users