Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 BSOD, Can't Boot, bootres.dll corrupted


  • Please log in to reply
2 replies to this topic

#1 Okami_Amaterasu

Okami_Amaterasu

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:32 AM

Posted 19 June 2018 - 01:20 PM

Hello,

I have had an issue starting last afternoon where my PC hard-restarted in the middle of use and was unable to boot back into Windows 10.

I have had issues with screen flickering and the screen suddenly turning black before and this is the second time it hard resetted (the first time was a while ago but my PC was able to successfully boot back up).  This time, and every time thereafter, my PC makes it to the Windows 10 loading screen before it suddenly stops loading, blacks out, and restarts.  After three restarts it goes into a diagnostics mode which is unable to resolve the issue but logs the issue under Windows/System32/LogFiles/Srt.  The log file suggests i:\boot\resources\custom\bootres.dll is corrupted.

After Googling and performing troubleshooting, system restore, startup restore, and all the other troubleshooting options to no avail, I arrived at https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/automatic-repairbootresdll-is-corrupt/582bd0ba-e29f-46b3-b347-2fd73c8556e3 which provided a solution involving bcdboot C:\windows /s V:.  I tried this command with C:\ replaced with the drive number for my Windows, /s linked to my system reserved partition (then in another attempt to a fresh 2GB partition), and /f as BIOS or ALL as I had a BIOS system.  I even tried /c once to not copy over any settings and that didn't work.

I also attempted bootrec command line commands trying to repair the master boot record which didn't work: https://support.microsoft.com/en-us/help/927392/use-bootrec-exe-in-the-windows-re-to-troubleshoot-startup-issues

I dual booted my Ubuntu and Windows, and could access neither (I could get into Grub though)

Interesting enough, I CAN boot Windows into safe mode with networking and the issue with suddenly crashing/restarting does not occur.  Through there, I tested my hard drive integrity, ran Malwarebytes, reformatted some disk partitions, and ran all of Window's troubleshooters to no avail.

In the end, I decided to clean boot Windows using a USB with a Microsoft ISO provided by their Installation Tool:

Sometimes, Windows would crash-restart while it's finalizing the setup and trying to get me to the desktop.  Other times, it would make it to the desktop and hard reset within 10 minutes.  In all circumstances I end up with the same issue of never being able to boot again (except in safe mode/safe mode with networking).

I unplugged my HDD so Windows would only use the completely empty SSD.  Even with a fresh, clean install of Windows 10 onto a completely empty SSD, it didn't work.  I also tried installing on the HDD, it didn't work either.

I am throughly baffled what could be causing this, is it a hardware fault?  Is it a software fault?  A Google search suggested that the bootrec.dll being corrupted error was the cause of a recent Windows update.  Still it's strange I wasn't able to boot into Ubuntu but I was able to boot into my bootkit.

SPECS:

I built this PC myself about 2 years ago, adding in an SSD later:

CPU: AMD FX-6300
GPU: ATI Radeon R9 270X
RAM: 8GB DRR3 1600MHz
OS: Windows 10 Home 64-bit
SSD: SSD 850 EVO 500GB
Hard Drive: Seagate ST1000LM014 1TB
Motherboard: MSI 760GMA-P34 (FX)
PSU: EVGA 500W

If anyone could help me that would be great!  If you need any additional information I am happy to provide.

Thanks!



BC AdBot (Login to Remove)

 


#2 Okami_Amaterasu

Okami_Amaterasu
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:32 AM

Posted 19 June 2018 - 08:24 PM

Just an update that I discovered the issue is related to AMD's graphic drivers, which seem to break when I install them. I'm not sure if I have a bad driver, if the latest Windows 10 update broke AMD's graphics drivers, or what could have occurred. It seems like the bootres.dll was a red herring, hehe.

With that, does anyone know of any other solution if AMD's drivers don't work or break my PC? Are there alternative drivers aside from the ones AMD provides? Is there another AMD or third party tool I could try? Should I just use the default Windows driver and tough it out? Don't wanna break my PC too much since all the restarts must be straining my motherboard.

 



#3 dmccoyks

dmccoyks

  • BSOD Kernel Dump Expert
  • 521 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:32 AM

Posted 20 June 2018 - 09:28 AM

More then likely it is just about finding the correct driver that works for you System. The newest driver isnt always best. Also follow link below to clean install your GPU.

How to Clean Install AMD Graphics Drivers
https://community.amd.com/thread/180667




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users