Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 Laptop Doesn't Recognize Mouse or Keyboard, Data Retrieval Mission


  • Please log in to reply
3 replies to this topic

#1 JohnTravolski

JohnTravolski

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:41 PM

Posted 18 June 2018 - 01:19 PM

Brief problem overview:

 

When turning on my laptop, I get to the Windows lock screen, but my laptop's keyboard does absolutely nothing and neither does my mouse or touchpad.  The only thing I can do here is shut the laptop off by holding the power button.  Since I can't get into Windows and I have no idea what's wrong, I want to recover the data on the drives somehow.  Unfortunately, safe mode didn't work, and when booting from Linux on a USB drive, two of the three drives in this laptop are not recognized (both of which are NVME drives), and I need to retrieve some data from those drives.  The SATA HDD is recognized by Linux, but in read-only mode.  I don't know what to do to get the data on the two NVME drives.

 

The details (there's a bit of a story to this, so hold on tight):

 

Last night, I was using Windows 10 Home Build 17134 on my personal ASUS ROG G752VY laptop.  I plugged in one of my NCredible PNY 32GB flash drives (that was most likely corrupted in some way because it had write protection unintentionally enabled on it) and I plugged in another one of my functional flash drives (a Verbatim 32 GB drive) to try and move files over from the PNY to the Verbatim flash drive.  Only one problem; for some reason, Windows only recognized the PNY drive, and not the Verbatim no matter how many times I plugged it in (I unplugged and replugged the Verbatim drive probably somewhere around 6 to 10 times, including in different USB ports on the laptop), even though one of my older laptops recognized the Verbatim drive with no problems.

 

So I thought, why not try the solution to everything; let's restart the computer, right?

 

Big mistake.  If only I had known what was to come.

 

With both the PNY and the Verbatim flash drives still plugged into the USB ports on the computer, I restarted Windows 10.  When the lock screen appeared, pressing keys on the keyboard did absolutely nothing (normally pressing a key opens the lock screen and brings you to the field where you enter your password), and no mouse that I plugged in, wired, wireless, or even the touchpad, would move the cursor (the cursor didn't even appear on the lock screen).  Plugging in a wired external USB keyboard also did nothing.  So the only thing I could do was press and hold the power button to shut it off.

 

After waiting a few minutes, I pressed the power button again, turning the laptop back on.  Windows booted up, taking me to the lock screen... and still nothing worked.  The keyboard does nothing, and neither does any mouse or the touchpad.  Desperate, I decided to turn it off and try again.

 

This time, when the manufacturer logo appears before booting into Windows, I see the text "Please wait..." at the bottom, and it takes me to Windows advanced recovery options.  And guess what!  When I'm in here, the mouse and keyboard both work!  So this indicates that it's an issue with my specific Windows installation, not with the hardware.  So once I'm in here, I try several different options:

 

First, I try booting into safe mode.  This time, instead of showing me the typical lockscreen with the time, it immediately shows me the field where I enter my password.  Unfortunately, even in safe mode, the mouse, keyboard, touchpad, and even external keyboard all still do absolutely nothing.

 

Then I tried "startup repair," but it reported that it couldn't do anything, so that didn't help much.

 

At this point, it was 3 AM, so I was too tired to continue; I gave up, unplugged the laptop, went to bed hoping that it would be magically fixed in the morning.

 

Well, it wasn't; all the same issues persisted this morning, so I decided that the best thing for me to do would be to at least get the files off the drive that I needed quickly.  So I put xUbuntu on an external SanDisk Ultra flash drive (using a different laptop to do this), booted into the BIOS on the ASUS ROG laptop (the laptop's keyboard works in the BIOS), and changed the boot priority to the flash drive.

 

I didn't fully install xUbuntu; I just ran the "try Linux" option you get whenever you boot from a drive you wrote an xUbuntu ISO to.  So now I'm inside xUbuntu (running on the SanDisk flash drive), and my keyboard and mouse are working perfectly.  I can navigate around, so I go to check the disks; but guess what; GParted and xUbuntu only see the 1TB HDD inside the laptop, and I can't access the other two drives; it doesn't see the 256GB NVME SM951 drive that Windows is installed in, nor does it see the other, separate 256GB SM951 that I have some important files on (these SM951s were never running in RAID, Windows always treated them as two separate drives).  Great.  In addition, for some reason, the HDD drive that it does see will let me copy files from the drive, but it won't let me delete any files from it (every file and folder has a lock icon next to it).

 

Researching this problem, apparently I need to change the SATA Mode Selection in my BIOS to "ACHI," but of course my BIOS only shows "RAID" for some reason (there's nothing else to select).  So that solution apparently won't work.  At this point, I honestly don't know what to do.

 

Whenever I'm in the advanced startup options, I do see the choice to "remove everything and reinstall Windows," which theoretically should fix the problem based on my observations.  However, I do have important files on the C: Drive that I would like to manually back up before trusting that this option won't remove them.  Theoretically, everything on the other NVME SSD would be unaffected.  I just want to save this as the last resort, though, and only use it after I've got all the data on these drives backed up.

 

I could take apart the computer and remove the drives, but don't have the hardware necessary to retrieve data from the NVMe drives outside of that laptop.  I also really don't want to spend any money.

 

So, it's been a relatively fruitless adventure so far, and I honestly don't know what to do.  Does anybody have any idea what actually happened here or what I need to do in order to get the data off the two NVMe drives?  Any help is greatly appreciated.  Thank you.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,024 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:41 PM

Posted 18 June 2018 - 01:31 PM

Great.  In addition, for some reason, the HDD drive that it does see will let me copy files from the drive, but it won't let me delete any files from it (every file and folder has a lock icon next to it).

 

This is most likely do to the Windows 10 FastStartup hibernation file. When that is active Ubuntu can only read the drive, not write to it. If you boot a Windows 10 install disk does it detect the NVME drivers. 

 

Boot Windows 10, select Repair Computer > Troubleshoot > command prompt. Type:

 

diskpart

list disk

 

Are the NVME drives detected? If they are detected you could copy over the files needed using DOS commands.

 

Instead of Linux you may have better luck using Lazesoft Recovery Suite and it's file manager. On another computer run the program and select the target computer's OS in the dropdown box.

 

http://www.lazesoft.com/lazesoft-recovery-suite-free.html

 

Edit: What version of XUbuntu did you burn. I would think Mint Cinnamon v18.3 would have the NVME drivers in it's kernel though it is based on Ubuntu.

 

https://blog.linuxmint.com/?p=3457

 

Edit: The Lazesoft Recovery Suite has two File Managers, one being the Lazesoft File Manager and the other Windows File Manager. The Lazesoft File Manager is an icon on the Desktop of Lazesoft. The Windows File Manager is opened by clicking the Recovery Suite icon on the Desktop. The Windows File Manager is opened by clicking a button in the lower middle window of the Recovery Suite.


Edited by JohnC_21, 18 June 2018 - 01:52 PM.


#3 JohnTravolski

JohnTravolski
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:41 PM

Posted 18 June 2018 - 03:38 PM

You just saved my life.  I didn't have time to try everything, but I got into the command prompt from the advanced repair options menu, it detected the NVME drives, and I was able to copy the imminent files that I needed to an external USB drive and finish my work on another machine.

 

Thank you so much, I will let you know when I learn more details about what happened.


Edited by JohnTravolski, 18 June 2018 - 03:39 PM.


#4 JohnC_21

JohnC_21

  • Members
  • 24,024 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:41 PM

Posted 19 June 2018 - 07:47 AM

Your Welcome, and thanks for taking the time to post an update. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users