Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Network card/driver failing


  • Please log in to reply
26 replies to this topic

#1 blitzjg

blitzjg

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 15 June 2018 - 09:56 AM

I made a topic about a year ago that read: 

 

"Hi everyone,

 

My computer (Windows 10) recently started waking up from hibernation with no internet connection (100% of the time). FYI I connect via an ethernet cable.  The first few times I thought it was an internet issue as repairing indicated "there is no internet connect" if I remember correctly.  Restarting my computer was how I first solved this problem the first several times it happened.

 

Now I learned I could go into device manager and scan for hardware changes, and that would sometimes rectify the network adapter issue.  I noticed sometimes this didnt work so more recently I just disable and re-enable the device and it restores the internet fine."

 

Here is a link for reference: https://www.bleepingcomputer.com/forums/t/650923/network-adapter-ethernet-problems/#entry4278283

 

This never really got resolved on this forum and I just lived with it for the past year.

 

A new problem started occuring where sometimes after waking up my PC would not detect a network card at all, but a restart would fix this.

 

Yesterday I came home and booted up my computer and it was not able to connect to the network.  Initially, under device manager instead of listing my Network Adapter, it listed an unknown Ethernet controller.  I tried several things, restarts, scanning for hardware changes, and anti-viral/malware scans (all of which found no issues). It started showing up as a Network Adapter again, this time with a #2 which I don't recall being there before and a red mark indicating it is not starting or working properly. The card is an intel 82579v gigabit network driver. I tried installing the latest driver and it did nothing.

 

Please help.  I hope I don't need a new network card, but if there is a way to know for sure I'd prefer that rather than constant issues and not knowing.

 

Thanks.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:18 AM

Posted 15 June 2018 - 12:20 PM

In Windows 10 do a Network Reset. Does that help?

 

  1. Select the Start  button, then select Settings  > Network & Internet  > Status > Network reset.
  2. On the Network reset screen, select Reset now > Yes to confirm.

    Wait for your PC to restart and see if that fixes the problem.



#3 mightywiz

mightywiz

  • Members
  • 790 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:18 PM

Posted 15 June 2018 - 03:07 PM

your not the only one that has issues with a computer coming out of hibernation or sleep mode!

 

don't use them and shut down your computer when not using it.

it's healthier for windows and not leaving your computer in a standby mode is better for your hardware components.

 

windows itself loves a full reboot.

 

on a side note try changing your IP from dynamic to static and keep an permanent assigned IP and you'll probably fix your issue.  with a dynamic IP when your computer is going to sleep that ip is releasing from the DHCP server and causing an issue in Hibernation/sleep modes.


Edited by mightywiz, 15 June 2018 - 03:11 PM.


#4 blitzjg

blitzjg
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 15 June 2018 - 07:42 PM

 

In Windows 10 do a Network Reset. Does that help?

 

  1. Select the Start  button, then select Settings  > Network & Internet  > Status > Network reset.
  2. On the Network reset screen, select Reset now > Yes to confirm.

    Wait for your PC to restart and see if that fixes the problem.

 

 

 

Very cool feature that I did not know existed... unfortunately it did not work.  I have some Windows Diagnostics I could share but not sure the best way to share them

 

I grabbed files from a diagnostic folder and thought I could look at them from my laptop since some of it required an internet connection, but they aren't in a readable format. 

 

It came with a NetworkConfiguration Cabinet File, several XML documents, 2 ETL files, and an XSL Stylesheet file..


Edited by blitzjg, 15 June 2018 - 07:48 PM.


#5 blitzjg

blitzjg
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 15 June 2018 - 07:44 PM

your not the only one that has issues with a computer coming out of hibernation or sleep mode!

 

don't use them and shut down your computer when not using it.

it's healthier for windows and not leaving your computer in a standby mode is better for your hardware components.

 

windows itself loves a full reboot.

 

on a side note try changing your IP from dynamic to static and keep an permanent assigned IP and you'll probably fix your issue.  with a dynamic IP when your computer is going to sleep that ip is releasing from the DHCP server and causing an issue in Hibernation/sleep modes.

 

 

I will keep that in mind and try that going forward if I can get this fixed :/



#6 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:18 AM

Posted 16 June 2018 - 08:32 AM

Disable Fast Startup. I believe you did this in the previous thread but you enabled it then disable. Open an elevated command prompt and type

powercfg,exe -h off
shutdown /s /f /t 0

Once the computer is shut down remove the power and  your battery if a laptop and easily accessible. Hold the power button down for 30 seconds. Attach the power and battery. Reboot. Sometimes a powercycle can get things back on Ethernet. 

 

If that does not work you can test the Ethernet with a live linux boot disk like Mint Cinnamon. Burn the iso to a DVD. Boot and wait till your are at the desktop. Try connecting to the internet. Your network icon is in the lower right.

 

If no Ethernet on Mint then you are probably looking at a new network card or USB adapter. The USB adapter is good if you have USB 3.

 

https://blog.linuxmint.com/?p=3457



#7 blitzjg

blitzjg
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 19 June 2018 - 08:16 PM

Disable Fast Startup. I believe you did this in the previous thread but you enabled it then disable. Open an elevated command prompt and type

powercfg,exe -h off
shutdown /s /f /t 0

Once the computer is shut down remove the power and  your battery if a laptop and easily accessible. Hold the power button down for 30 seconds. Attach the power and battery. Reboot. Sometimes a powercycle can get things back on Ethernet. 

 

If that does not work you can test the Ethernet with a live linux boot disk like Mint Cinnamon. Burn the iso to a DVD. Boot and wait till your are at the desktop. Try connecting to the internet. Your network icon is in the lower right.

 

If no Ethernet on Mint then you are probably looking at a new network card or USB adapter. The USB adapter is good if you have USB 3.

 

https://blog.linuxmint.com/?p=3457

 

I tried "powercfg,exe -h off" and it didnt work so I figured that comma was a typo and meant to be a period. When I tried it with the period it said "Unable to perform operation. An unexpected error (0x65b) has occured: Function failed during execution."

 

This was done in normal command prompt. I'm not sure what an elevated command prompt is.  But then I tried it in Adminsitrator:Windows PowerShell and it seemed to work (no error or printed output).  

 

This is on a desktop so after the shutdown is it sufficient to turn the power supply off and unplug the AC cord?



#8 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:18 AM

Posted 20 June 2018 - 07:42 AM

Yes, but it is okay if you simply pull the power cord after shutdown. Do not turn the power supply off. And sorry for the error on the commands.



#9 blitzjg

blitzjg
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 20 June 2018 - 01:31 PM

Yes, but it is okay if you simply pull the power cord after shutdown. Do not turn the power supply off. And sorry for the error on the commands.

 

No problem, as always I appreciate your help and quick responses. I will redo it again tonight because I did turn the power supply off. And I will follow up with the ISO test if that doesnt work.

 

I'm curious about the network card through USB 3, however my USB 3 ports are in the front and from my experience give power but don't recognize anything attached. A problem since I put my tower together.

 

Also should I download the 64-bit mint or 32?


Edited by blitzjg, 20 June 2018 - 01:33 PM.


#10 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:18 AM

Posted 20 June 2018 - 02:02 PM

Download 64bit Mint Cinnamon. It may wind up where you need to do a reset with the option to keep files if Ethernet  on Mint Cinnamon functions. 

 

One other thing you may want to try is Downloading Windows All in One Repair and only check Network Repair but I doubt it would work if Windows 10 Network Reset failed to fix the problem.

 

https://www.bleepingcomputer.com/download/windows-repair-all-in-one/



#11 blitzjg

blitzjg
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 20 June 2018 - 04:58 PM

After running the command upon restart, the fast startup option is gone, is that what was supposed to happen? I was going to enable/disable again and try a second time without turning off the power supply but the option was gone.  

 

The ISO is over 1.7 gigs, I assume I need a disc bigger than that?  All I have at the moment is 700mb discs


Edited by blitzjg, 20 June 2018 - 05:02 PM.


#12 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:18 AM

Posted 20 June 2018 - 07:27 PM

I don't have Windows 10 but the option disappeared when I disabled it in Windows 8.

 

You can either burn a DVD or use Rufus to create a bootable USB flash drive.

 

https://rufus.akeo.ie/

 

Attach the flash drive and run Rufus. Click GPT partition scheme in the dropdown box. Leave all boxes as checked. Where you see FreeDos in the dropdown box select iso image, click the icon and browse to the Mint iso file. Press Start.

 

Edit: Backup any data on the flash drive as it will be wiped.


Edited by JohnC_21, 20 June 2018 - 07:44 PM.


#13 blitzjg

blitzjg
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 20 June 2018 - 10:47 PM

So I had a couple boot options when booting from USB, there were 2 linux mint options:

 

Start Linux Mint Cinnamon 64-bit 

Start Linux Mint Cinnamon 64-bit (compatability mode)

 

After trying both, I get to a linux mint logo screen but there are no desktop icons or anything, any ideas?



#14 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:18 AM

Posted 21 June 2018 - 07:07 AM

That never happened to me. See if using MBR for a partition scheme in Rufus changes anything. 

 

Check the sha hash to your iso file and make sure they are correct. 

 

https://ftp.heanet.ie/mirrors/linuxmint.com/stable/18.3/sha256sum.txt



#15 blitzjg

blitzjg
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 26 June 2018 - 07:20 PM

Unfortunately it checks out as the 64 bit version and MBR did the same thing =(






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users