Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

c000021a - <<The session Manager failed to create protected prefixes.>>


  • Please log in to reply
1 reply to this topic

#1 NonameNoname

NonameNoname

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:57 AM

Posted 08 June 2018 - 05:02 PM

Hi there!

 

 My build: Win7 x64 Pro (5 years), no restore point, last updates - spring 2017.

 

When I work on my PC I often put in into sleep mode instead of shutting down the comp and my PC may be able to work a few days w/o rebooting. In one day I noticed my Explorer began to work slowly and I rebooted Win7, and after that my booting became to get stuck on the Win7 logo.
I immediatly tried different modes ("Safe mode", "Last known good configuration" and etc.except "Boot with disabled digital signature", more info below) -  no luck. My "Safe mode" stoped to boot on one of *.sys files. When I booted from another new Win7, I noticed my crashed Win7 lost about 30 drivers in folder system32\drivers. When I copied the missing *.sys my booting continued but after logo I get:
 
STOP: C000021A 
The Session Manager faied to create protected prefixes system process terminated enexpectedly with a status of 0xc000003a (0x00000000 0x000000000).
The system has been shot down.

 
I tried "Repair your computer" and a couple times implement SFC and CHKDSK with no luck. After that I maked the copy my HDD and keep to work only with them. (CrytalDisk indicates my HDD has a errors and as it seems to me, this caused the loss of important system files).
 
What have I already done after that:
1) Tried to repair Win7 with MSDaRT.
2) Replaced registry files from RegBack.
3) Tried to catch dump files but as seems to me with this error it's not possible. 
4) Many times SFC and CHKDSK with different parameters. No something suspicious in CBS.log.
5) DISM /online /cleanup-image /restorehealth
6) bcdedit, bootcfg, bootrec.exe /fixmbr and etc..
 
When I tried "Boot with disabled digital signature" mode my Win7 booted somehow but my activation (WIndows Loader by Daz) is gone. First off all I checked drivers signature by sigverify and found out no signatures of the part of important drivers and DriverStore/FileRepository folder was almost empty. Copying files from new Win7 into FileRepository didn't yield any result. In addition I executed Autoruns and it found out more interesting result. Most drivers can't be found, despite all of this *.sys files which is on own places in system32\drivers
 
1545324_662018.jpg
 
I tried to repair lost files from original HDD by different software, but apparently FileRepository folder was empty before that error, Recuva and other didn't find out no one folder there. 
 
Besides I read that the same error could be resolve by deleting  MountedDevices parameter from HKEY_LOCAL_MACHINE\SYSTEM or deleting PendingFileRenameOperations from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager but none of this couldn't solve this error.
 
How can I restore catalog of digital signature Win7? Is it possible to implement automaticly or manually by copy from new Win7? Is it possible to solve by WIndows Update? I noticed when I install fresh updates after error, my FileRepository folder began to be filled by a little.
 
I attached the fresh CBS.log and the ProcessMonitor boot log.

CBS.log and BOOTLOG

 

UPDATE: Resolved!

Some of catalogs in с:\Windows\System32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} is missed. I copyed oemXXX.cat and prnXXXXX.cat from new Win7, and booted normally!


Edited by NonameNoname, 09 June 2018 - 08:53 AM.


BC AdBot (Login to Remove)

 


#2 jcgriff2

jcgriff2

  • BSOD Kernel Dump Expert
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey Shore
  • Local time:09:57 PM

Posted 08 June 2018 - 07:41 PM

Hi. . .

I found a blog covering this error in Windows 7 - https://blogs.technet.microsoft.com/askcore/2011/08/09/operating-system-comes-up-with-blue-screen-error-stop-c000021a/

I do agree with you - it is very likely that your hard drive is/has failed and resulted in the loss of important system files which left you in your current predicament.

I am not sure that you can recover from this. I think that you'll have to purchase a new HDD, load Windows 7 on it; connect your current HDD to the new W7 installation via a USB/HDD adapter; copy out all personal files from the attached HDD; re-install your programs and apps.

Keep in mind that each time you access the current HDD, you may be damaging it further causing additional files to be unrecoverable.

You may want to try and run chkdsk /r if possible.

You also may want to run a HDD diagnostic test on the HDD to verify that the HDD has failed.

Run SeaTools for DOS, LONG test - https://www.sysnative.com/forums/hardware-tutorials/4072-hard-drive-hdd-diagnostics.html

Good luck to you.

Regards. . .

jcgriff2

Edited by jcgriff2, 08 June 2018 - 07:42 PM.

Microsoft MVP 2009-2015
Microsoft Windows Insider MVP 2018 - Present




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users