Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows cannot access the specified device, etc


  • Please log in to reply
5 replies to this topic

#1 KPryor

KPryor

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 31 May 2018 - 05:11 PM

Trying to diagnose the problem on a Dell Inspiron laptop with Windows Vista. Double clicking the cd/dvd drive (E:\) gives the error message "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item. I've googled till I can't see straight but haven't found a solution. I would appreciate any guidance I can receive here.

Thank you,

Ken



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,713 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:35 PM

Posted 31 May 2018 - 05:36 PM

Does Device manager show the opical drive ?  If it does, double click on it to get to the properties panel and, under 'Drivers' uninstall the drivers then re-boot. Windows should installl fresh drivers when it re-boots. If that doesn't work run 'Cmd' as administrator and try SFC. When 'Cmd' opens types 'SFC /SCANNOW' (without the ' ', and note the space between SFC and /SCANNOW) and see if it fixes any file problems.

 

If the optical drive doesn't show up in Device manager check 'View - Hidden devices'. If it still doesn't show up it may be dead. Try a spare drive if you have one.

 

Chris Cosgrove



#3 KPryor

KPryor
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 31 May 2018 - 08:16 PM

Thanks for the reply and suggestions. I ran sfc /scannow and it said it did find some errors and that it fixed them. The drive does show up in Device Manager. I tried uninstalling it in Device Manager and then rebooted to let it "find" it again. Still having the same issue. I put in a known good drive as well without success. I can put an audio CD in and play it via VLC player, but if I just double click E: drive in the Computer Explorer window, I get the error. I can also right-click the E:\ drive in Computer and select "Play with VLC" and it works. The only issue I'm having is if I double click it with a disk in the drive which always gives me the error. This isn't a critical issue, but I'd like to fix it if possible.



#4 Abzyx

Abzyx

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 01 June 2018 - 02:53 PM

If you simply insert an audio CD, nothing at all happens automatically? No window opens on your desktop? My hunch is something like AutoPlay is set to automatically play audio CDs with a program that is no longer installed. This tutorial might be helpful:https://www.vistax64.com/threads/autoplay-settings.78021/ .



#5 Abzyx

Abzyx

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 02 June 2018 - 12:52 PM

I have experimented on my old Vista system since my last post. In my case, double-clicking an optical drive in Computer as you describe opens an audio CD in Windows Media Player 11. I believe I could change that to iTunes via Control Panel > Default Programs > Set program access and computer defaults. However, VLC (I have 2.2.4 installed) does not appear as an option for "Choose a default media player" there for some reason, perhaps an option that I did not select upon installation. I have looked at https://wiki.videolan.org/VLC_HowTo/Make_VLC_the_default_player/ but that seems to be concerned more with file associations. Regarding your error message, I now suspect that your default media player was uninstalled.

 

Anyway, if you would like audio CDs to launch automatically in VLC without opening Computer and right-clicking the optical drive, you should certainly be able to do that via AutoPlay settings (at least I can).



#6 KPryor

KPryor
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 02 June 2018 - 01:57 PM

My apologies for taking so long to respond. The owner of the laptop has it back now and is satisfied with using it the way it was at the time that I first posted here. I did install VLC player and I will tell him I can make it the default if he wants me to. I appreciate the help and information. Thank you very much!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users