Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Usb hub malfunction


  • Please log in to reply
No replies to this topic

#1 Rigel11

Rigel11

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:DK
  • Local time:01:28 PM

Posted 30 May 2018 - 03:09 PM

Had my motherboard out earlier, with all connectors removed (leaving only the gpu, ram and cpu in place). Put everything back together only to find Windows 7 now refuses to recognize my powered usb 3.0 hub. It only shows up as an unidentified device, no matter what I do (unplug/plug, reboots, different port). To be honest I'm not sure what it identified it as before, it simply worked. No manufacturer drivers supplied.

 Curiously I tried to remove the device in Windows and add it back, only to have Windows find the wireless mouse connected to the hub instead (although the driver install failed, and it doesn't work.)

 

Devices connected directly to the motherboard seem to work fine though, just not the hub. I'm sure I'm not the first person with this problem but I've looked around online and found no solution so far. Tried disabling power management on usb ports and also ran the Windows usb diagnosis fix thing. Any other ideas?

 

 Running Windows 7 64 bit on
 

  • Phenom II 965
  • Gigabyte GA-990XA-UD3
  • DDR3 2x4GB
  • Gigabyte GTX 660
  • Thermaltake 750w


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users