Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BSOD DPC_Watchdog_Violation


  • Please log in to reply
2 replies to this topic

#1 strfker

strfker

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:06 AM

Posted 29 May 2018 - 07:26 PM

So I only get the DPC Watchdog Violation when using Deluge while connected to my VPN (PureVPN via the desktop program). I have no issues when using Deluge without the VPN. I have tried changing the hard drive drivers to no avail. These are the steps that I followed:

 

When you upgrade from Windows 7, or Windows 8, 8.1 to Windows 10, sometimes, you may get this annoying BSOD error. It occurs because of the iaStorA.sys driver that isn’t fully compatible with Windows 10.

To resolve this BSOD error, you can replace that problematic driver with the storahci.sys driver from Microsoft. Here are the steps you need to follow:

Press Windows + X and then press M to bring up Device Manager.

Locate and expand the “IDE ATA/ATAPI controllers” option on the list.

Right-click on the “Standard SATA AHCI Controller” or any other controller that has “SATA AHCI” in the name.

Note: To verify that you have chosen the correct one, click on the Driver tab -> Driver details. If the iaStorA.sys is on the list, then you have selected correctly.

In the Properties of Standard SATA AHCI Controller, select the Driver tab, and choose “Update Driver…” option.

Next, choose “Browse my computer for driver software” option and then select, “Let me pick from a list of device drivers on my computer“.

Select “Standard SATA AHCI Controller“, click on the “Next” button, and then restart your Windows 10 PC.

 

 

I have since changed the drivers back to the automatically selected ones.

 

Any help would be much appreciated! Thanks.

 

http://speccy.piriform.com/results/BgphUFZQyEIxxp4HkvBGQST

Attached Files



BC AdBot (Login to Remove)

 


#2 dmccoy

dmccoy

  • BSOD Kernel Dump Expert
  • 1,028 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:06 AM

Posted 01 June 2018 - 04:16 PM

Those are not the best steps to change from IRST to AHCI mode. I do not see anything in you dumps relating the iaStorA.sys driver though. It seems to point to the following driver: asmtxhci.sys Timestamp: Fri Aug 16 14:28:42 2013.

 

Create a Restore point before updating drivers.

 

Update the driver and any other outdated ones from the following link. Let me know if this resolves your issue or not.

 

https://www.asus.com/us/Motherboards/X79DELUXE/HelpDesk_Download/

 

 


We are all volunteers so please by kind, courteous and respectful of all staff and members

 

I try to respond in 24-48 hours normally and I am more active on weekdays than weekends. However, sometimes due to my health, family or life it may take me a little longer. If you have not heard from me within 72 hours then please PM me a reminder. 

 

BC BSOD Posting Instructions 


#3 axe0

axe0

  • Malware Study Hall Junior
  • 341 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Netherlands
  • Local time:04:06 PM

Posted 08 June 2018 - 01:59 AM

Please temporary uninstall Kaspersky as well and use Windows Defender as alternative while troubleshooting.


Kind regards,
Axe0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users