Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot access to BIOS/UEFI/boot options on Lenovo h50 desktop with windows 10


  • Please log in to reply
7 replies to this topic

#1 ytlnytlnytln

ytlnytlnytln

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:10:03 AM

Posted 26 May 2018 - 06:41 AM

I got this computer used and want to install Windows 7 to it. So I followed whatever instruction I found on the web, got into advanced restart setting on W10, somehow found UEFI firmware settings. Restarted, got into UEFI, changed boot order to USB everything and THEN HDD. Inserted W7 installation USB stick I prepared using Rufus with UEFI and FAT32 settings.
1) It won't boot up.
2) There is no Lenovo splash screen when starting up. It either goes directly into W10 or doesn't even turn the monitor on.
3) Somehow (I think I'm going crazy) "UEFI firmware settings" option in the settings has gone. I don't have that anymore. I check via system information window, it still shows UEFI, not BIOS.

F1, F2, F8, F10, F12 is out of the question, it does not even look for an input. If I disconnect the HDD, it does not power up the monitor. It insists on booting directly to W10 without any prior screen signal or not booting at all. I've never used a UEFI PC before. I already hate it. So, what to do now? Sorry if this is the wrong section, I really don't now what's wrong so... Thanks in advance.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,024 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:03 AM

Posted 26 May 2018 - 08:35 AM

 FYI, it would be a good idea to first disable FastStartup in Windows 10. After disabling FastStartup open a command prompt and type:

powercfg.exe -h off
shutdown /s /f /t 0

Reboot and see if tapping F1 can access your UEFI. If not:

 

Can you access UEFI doing the following?

  • Log out of Windows and go to the sign in screen.
  • Hold down the Shift key on your keyboard while clicking the Power button on the screen. Continue to hold down the Shift key while clicking Restart.
  • Hold down the Shift key, the computer will open a bluescreen with the options to continue
  • Click Troubleshoot --> Advanced options --> UEFI Firmware Settings --> Restart. You will enter BIOS setup utility interface.

https://support.lenovo.com/us/en/solutions/ht500217

 

You need to disable SecureBoot in UEFI settigns before Windows 7 can boot, You should also disable FastBoot or it may be called QuickBoot in your UEFI settings.



#3 ytlnytlnytln

ytlnytlnytln
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:10:03 AM

Posted 26 May 2018 - 09:58 AM

Thanks. I get this message after powercfg.exe command:

"unable to perform operation. An unexpected error (0x65b) has occured: Function failed during execution."

 

I get into advanced options but there is no "UEFI firmware settings" option there.



#4 JohnC_21

JohnC_21

  • Members
  • 24,024 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:03 AM

Posted 26 May 2018 - 10:06 AM

Use an elevated command prompt for the two commands.

 

Press the Windows key + X, command prompt as admin. It may be called powershell. 

 

Edit: Did you disable Fastboot in Windows 10?


Edited by JohnC_21, 26 May 2018 - 10:06 AM.


#5 ytlnytlnytln

ytlnytlnytln
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:10:03 AM

Posted 26 May 2018 - 11:22 AM

I got the same message. I turned fast startup off in Windows power settings.


Edited by ytlnytlnytln, 26 May 2018 - 11:26 AM.


#6 JohnC_21

JohnC_21

  • Members
  • 24,024 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:03 AM

Posted 26 May 2018 - 11:55 AM

If you have powershell listed instead of command prompt change the setting to command prompt and then use command prompt as administrator.

 

https://www.windowscentral.com/how-add-command-prompt-power-user-menu-windows-10-creators-update

 

Command prompt as administrator will be

 

C:\Windows\System32>



#7 ytlnytlnytln

ytlnytlnytln
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:10:03 AM

Posted 27 May 2018 - 12:33 PM

Ok, I did the "powercfg.exe -h off" thing. But UEFI settings option in Windows is still missing. I can't believe there isn't a straightforward, simple workaround to this problem. Suppose my HDD is broken. Wouldn't the BIOS let me boot whatever drive I insert to the PC? It won't let me boot anything. I tried a bootable USB stick, a Windows 10 installed HDD from another PC. Nothing boots. Is the UEFI totally broken and I need to trash the mainboard? How stupid is this?



#8 JohnC_21

JohnC_21

  • Members
  • 24,024 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:03 AM

Posted 27 May 2018 - 02:52 PM

Yes, by tapping F1 at boot you should be able to access the UEFI settings even if there is not HDD installed. I don't understand why you cannot access the UEFI settings. That is strange. As soon as the computer boots do you tap F1, not press it? I believe tapping at F12 at boot will give you  the boot menu with the option to boot your USB device.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users