Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 can't see HDs but BIOS can


  • Please log in to reply
2 replies to this topic

#1 Cathryn33

Cathryn33

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:10:16 AM

Posted 23 May 2018 - 10:19 AM

Background:

 

Okay, so one of our computers had an issue where it wouldn't display anything on the screens, at first we thought it was a video card error so swapped out the card, no luck, checked and swapped out the cables, swapped out the RAM, nothing. At this point we rang the local computer shop to get a quote on them doing a diagnostic but they had a 5 day wait, so we thought we'd try a bit more before booking it in. The guy on the phone suggested resetting the BIOS by removing a battery on the motherboard for 5 mins, so we did that (possibly foolishly). Didn't work.

 

Anyway, while we were just standing there looking at the black screens, the power cut off and restarted a couple of times, so we thought - power supply! We went and bought a new power supply and installed it and voila! the screens came on when the PC booted up.

 

The actual problem:

 

So here's where it gets tricky. On bootup, it asked to press F1 to setup BIOS or F2 to restore defaults. We opted for F2 as the BIOS had never been customised. Proceeding through the boot process, it asks for a boot disk. Damn.

 

This computer has 5 internal drives installed, so we go into BIOS and have a look. The drives are there, we play around with boot sequence (not knowing the drives by their "true" names, it took a while to find the bootable one). Weirdly, that drive comes up as [Not detected] on the Main page, but is shown in the Boot Device Priority section of the Boot settings page and able to be selected as the IDE drive.

 

Once we got it to boot into Windows at last, everything looked normal, same desktop settings, internet connection etc. But the drives are not visible in File Explorer and they are also not visible in Disk Management, not even as unmapped drives. A lot of programs are installed on drives other than the boot drive, so hardly anything runs. A prompt asking for the location of the program appears when the shortcut is run.

 

Any help would be appreciated

 

Trying to google this error comes up with lots of new drives that are not recognised by Windows 10 but not existing drives that have disappeared en masse. Formatting is not an option we would like to take, obviously. But the fact that all four drives are "missing" seems like it's not a problem specific to the drives themselves but more something in the software reading them.

 

Anyway, we are currently stumped, so if anyone else has had the same kind of problem or has an idea about how to find the missing drives, that would be awesome.

 

Thank you.

 



BC AdBot (Login to Remove)

 


#2 Cathryn33

Cathryn33
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:10:16 AM

Posted 23 May 2018 - 10:45 AM

Bah, so right after giving up and posting this, we saw the option to change IDE mode from Enhanced to Compatible, so tried it. That worked, so simple.

 

Anyway, hope that helps someone else at some point :)



#3 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,761 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:16 AM

Posted 23 May 2018 - 03:57 PM

Thanks for posting your solution.

 

Chris Cosgrove






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users