Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Copy and Paste Issue Server 2012 R2


  • Please log in to reply
2 replies to this topic

#1 auhc

auhc

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:32 AM

Posted 14 May 2018 - 04:54 PM

I have RDS setup with one domain controller and a session host, which our users RDP into to work. We use copy and paste for a couple essential functions, and it had been working just fine until Thursday last week. I was updating GP to be a bit more secure on the Session Host. Now, files cannot be copied and pasted. Thinking I had set something too restrictive, I un-enforced that GPO, but, even with no GP enforced, we cannot copy and paste files with this host. I can copy and paste to the DC. I can copy and paste text to/from the session host. I tested the GP by enforcing it and restricting users from changing desktop background. It worked, the policy was enforced and when I changed that policy back to allow changing of desktop wallpaper, users were able to do so. So the Session Host sees the DC and reads/applies policy correctly. RDP clients are setup correctly, with appropriate local resources (clipboard, drives, etc.) checked before remoting in, and users can print from the remote host to their local workstations. I'm working from a Windows 10 machine version 1803, build 17134.48. I've connected with both the legacy RDP client and the Windows 10 app. I've tried killing and restarting rdpclip on the host, with no effect.  I'm not sure what else to do, other than maybe try some other remote client to connect to the server with. Luckily, the files we need can be uploaded to OneDrive. I just don't want people browsing on the server. The less they do there, the better, and typically there's only one user other than myself who has any real need to transfer files from the host. It's got to be some simple setting somewhere that I inadvertently changed. 

Suggestions are welcome. 🙂



BC AdBot (Login to Remove)

 


#2 Bulgaristan

Bulgaristan

  • Members
  • 294 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bulgaria
  • Local time:10:32 AM

Posted 01 June 2018 - 10:20 AM

You can try with this registry but if you applied a GPO I`m afraid you will need to find it :) 

  1. 1. Follow the below path: C:\Windows\System\ and click IEMIGRAT.DLL > On the File menu, click Rename;
  2. 2. Rename the file as lemigrat.dlx and close Windows Explorer;
  3. 3. Click Start > Run > type: regedit and click OK;
  4. 4. In Registry Editor, click My Computer > Click Export Registry File on the Registry menu;
  5. 5. Select a safe location to save the exported file;
  6. 6. In the File name box, type the name for new file and click Save;
  7. 7. Click:  HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Setup/Migration in Registry Editor > find and click the 100 key in the right pane;
  8. 8. Click Delete on the Edit menu > Click Close on the File menu and then close all programs;
  9. 9. Restart PC and insert Windows Millennium Edition installation CD-ROM and follow the installation instructions to complete the process.

 

You can check if those are Enabled 

1- Create a new GPO

2- Navigate through User Configuration / Windows Settings / Internet Explorer Maintenance / Security.

3- Double-click Security Zones and Content Ratings.

4- Select the Import the current security zones settings radial button and press the Modify Settings button.

5- In the Select a Web content zone to specify its security settings section, select My Computer.

6- Press the Custom Level button.

7- Scroll the Security Settings to Downloads and set File download to Enable.

8- Scroll to Miscellaneous and set Drag and drop or copy and paste files to Enable.

9- Press OK, OK, and OK.



#3 Bulgaristan

Bulgaristan

  • Members
  • 294 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bulgaria
  • Local time:10:32 AM

Posted 01 June 2018 - 10:24 AM

Oh right I forgot
Open elevated administrator command prompt and use :

  

Sfc /scannow 
 

once finished run

 

dism /online /cleanup-image /restorehealth
 

I hope that helps 






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users