Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Time Change After Using Linux Live DVD?


  • Please log in to reply
8 replies to this topic

#1 sikntired

sikntired

  • Members
  • 1,002 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:03:09 AM

Posted 05 May 2018 - 07:05 AM

I downloaded Linux Mint Cinnamon 18.3 to use as a Live DVD. Yesterday, I inserted it and used it just to get more familiar with utilizing Linux as I intend to gravitate away from Windows. When I was done the DVD was ejected. However, I just happened to look at the time on the computer and it was off by about four hours??

 

This is the link for the download:  https://www.linuxmint.com/edition.php?id=246 (University of Oklahoma).

 

Can anyone give me a clue as to why this happened?? I've downloaded and used Linux Mint 17.2 cinnamon in the past with no problems. :scratchhead:



BC AdBot (Login to Remove)

 


#2 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,077 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:04:09 AM

Posted 05 May 2018 - 07:33 AM

This can happen, the way linux reads time and the way windows reads time are different so this happens a lot.

Even with a live this can happen from time to time.


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#3 JohnnyBeeGood

JohnnyBeeGood

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Local time:04:09 AM

Posted 05 May 2018 - 09:00 AM

Double check which time zone Mint is set for.


Edited by JohnnyBeeGood, 05 May 2018 - 09:01 AM.


#4 rufwoof

rufwoof

  • Members
  • 120 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 05 May 2018 - 11:13 AM

Its usually due to the liveCD not setting the hardware clock to UTC or something like that.


OpenBSD


#5 pcpunk

pcpunk

  • Members
  • 5,882 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:04:09 AM

Posted 05 May 2018 - 12:30 PM

When you boot up, just go ahead and change the time zone date etc. to whatever you want and maybe that will help, that is what I usually do if I'm not in a hurry.


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#6 sikntired

sikntired
  • Topic Starter

  • Members
  • 1,002 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:03:09 AM

Posted 05 May 2018 - 01:37 PM

I don't recall having to do that when I created a Live DVD for Linux Mint 17.2 Rafaela Cinnamon in 2015. Has this changed since then?

 

Thanks to all for your input.



#7 rp88

rp88

  • Members
  • 3,024 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:09 AM

Posted 05 May 2018 - 04:25 PM

I get this too, I think because I am in Britain where we switch between GMT and BST time (1 hour difference) depending on the time of year, when this happens to me it tends to relate to, I think, Windows and Linux trying to handle the timezone in a different way to compensate for this.

I also had a really weird event once where after having been using a live USB I booted windows on the hard-drive and found the dates to be showing as the year 11000 or so. It was quite amusing to see how everything was going really slow, I guess because Windows was having to do a lot more work on many more digits every time a time or date calculation was done, but it was all fixed after resetting the clock to the true date and restarting windows a few times. Unfortunately I never had the presence of mind to try opening some software on windows while the future date was set to several millenia away, would have been interesting to see which things would have been able to survive the 2038 problem or year 10000 problem.

Edited by rp88, 05 May 2018 - 04:26 PM.

Back on this site, for a while anyway, been so busy the last year.

My systems:2 laptops, intel i3 processors, windows 8.1 installed on the hard-drive and linux mint 17.3 MATE installed to USB

#8 Gary R

Gary R

    MRU Admin


  • Malware Response Team
  • 838 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:09 AM

Posted 06 May 2018 - 12:13 AM

Found this article about time zones in Linux and Windows which is quite informative ... https://askubuntu.com/questions/169376/clock-time-is-off-on-dual-boot



#9 JohnnyBeeGood

JohnnyBeeGood

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Local time:04:09 AM

Posted 06 May 2018 - 03:59 AM

Thanks Gary R :)

 

I wondered why the time in my Windows install was always off :hysterical:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users