Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

powershell has stopped working - pop up


  • Please log in to reply
2 replies to this topic

#1 irvineboy

irvineboy

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:06:56 PM

Posted 02 May 2018 - 12:09 AM

I was so excited as I got a new laptop.  It has windows 10 and as I am turning it on for the first time and going through installation, I am installing basic files like Adobe Reader, Malewarebytes free edition, SuperAntiSpyware free edition, winamp, winrar. etc

 

I keep getting this popup saying "powershell has stopped working" A problem caused the program to stop working correctly.  Windows will close the program and notify you if a solution is available.  There are no additional error messages.  I googled it and people said to run Malewarebytes and it should remove it but it is still popping up.  Another video says to go to Control Panel and Uninstall Program and on the upper left hand side, go to "Turn Windows features on or off" and uncheck  Windows Powershell 2.0 but that does not work either.  Is that the only solution or is there another way than to just turn it off?

 

It's a fairly new laptop so not sure what is causing it.  Can anyone help me remove this pop up?


Edited by irvineboy, 02 May 2018 - 12:30 AM.


BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,157 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:09:56 PM

Posted 02 May 2018 - 08:44 AM

The first thing I'd try:

 

 

Had I started encountering this with a brand new out of the box machine I would have promptly returned it for an exchange.  These are not the sorts of problems one should ever be experiencing at that point in the computer's life and prior usage (virutally none) cycles.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

      Memory is a crazy woman that hoards rags and throws away food.

                    ~ Austin O'Malley

 

 

 

              

 


#3 irvineboy

irvineboy
  • Topic Starter

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:06:56 PM

Posted 02 May 2018 - 11:23 AM

OK, I ran the Powershell session and SFC /scannow

After it completed 100% verification, it showed that "Windows Resource Protection found corrupt files and successfully repaired them.  Details are included in the CBS.Log windir\Logs\CBS\CBS.log

 

Then I ran the DISM /Online /Cleanup-Image /RestoreHealth

The operation completed successfully = 100% scanned

 

Should I check the "Windows Powershell 2.0" folder under "Turn Windows features on or off" in the Control Panel?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users