Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External hard drives not showing up


  • Please log in to reply
3 replies to this topic

#1 tzoromski135

tzoromski135

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Local time:07:13 PM

Posted 28 April 2018 - 03:14 AM

First off, yes, I know there are other topics regarding this issue.  I've tried several solutions only to have them not work or work, then they don't.  It's complicated which is why I am here asking for help.

 

I have 2 external hard drives by Seagate - 8TB each and I use them to save my music and videos for my business.  After about 4 months of not using them, I hook them up to my PC with windows 10 installed. 

 

Now, I have had to do the following MOST of the time: right click on windows, disk management and add a letter to the drive, however this time, they didn't show up. 

 

I go to device management and the drives show up, but don't populate.

 

I've had this issue when I upgraded to windows 10 and I have had to use testdisk, so I kept testdisk in case it happened again.  Last week, I was able to get testdisk to see them both and it said it could repair the MBR on the drives, but after the repair, Windows still did not load the drives on disk management, but still showed them on device management.  SO I had to go back into testdisk and start copying one of the drives to a new Western Digital 4TB HD, but was unable to finish copying the drive to the new drive before I had to use it at a work event last week.

 

Today I went to finish the copy and now testdisk is showing the attached screenshot.  I tried to load the seagate drive 1st by selecting the 4th option down - testdisk would not do anything.  I tried the 6th option down, testdisk would not do anything again. 

 

I'm assuming that the MBR on the external drives are somehow corrupt, even though I have windows disconnect the drives prior to shutting them down.  So now I need to start fresh over, but in order to do that, I need to finish copying my drive so I don't lose my files.

 

Please help me get these drives copied. thank you.

Attached Files



BC AdBot (Login to Remove)

 


#2 Havachat

Havachat

  • Members
  • 1,136 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sleepy Hollow - Geelong - Go Cats.
  • Local time:11:13 AM

Posted 28 April 2018 - 09:36 AM

Can only add what i think i know , i have a 8TB drive for my Backups running in a Caddy Rack { Sata Cable runs to Mobo }, i insert the Drive and Boot the PC and have no issues in Data Transfer or Creating and Storing my Backup Images.

I can also HotSwap with the Caddys if the PC is Running with no issues.

 

Are you running USB Powered External Drives ? That may be the issue / or something / if you connect and its not recognised or accessible.

I would connect first and Reboot then it should recognise and allocate an available Drive Letter , if not then it may be a USB Driver issue not being able to detect the drive if the PC is allready running

 

You stated repairing MBR on these drives ? ....why would you have a Master Boot Record on an External Drive ? unless it has an Operating System also , but then that would be Dual Booting and i dont think you do.

I run all my External Drives { Over 2 TB } as they are , Inititilized - Formatted with GPT , and Create what ever Folders i Choose to use on them.

 

I have had no issues with any Drive sitting for 2 -12 mths or longer , insert and away we go.

Well thats my view , you may add your Speccy Report or PC Model and Make for others to assist you , and running MiniToolBox if directed to do so ,  to view Windows Event Viewer Errors to any reasons for your issue.



#3 JohnC_21

JohnC_21

  • Members
  • 24,449 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:13 PM

Posted 28 April 2018 - 09:39 AM

Just my thoughts in addition to Havachat's.

 

I am not sure how you could repair a MBR on the 8TB disk as anything over 2TB needs to have a GPT partition table and GPT disks do not have a MBR. They use a GUID table. 

 

I can't say for sure but if these drives were attached when Windows was shutdown the problem could be the Windows 10 hybrid shutdown which uses a hibernation file for faster startups.

 

If you need to get data off the drive I would do the following. Firstly if the computer was pre-installed with Windows 8 or 10 disable Fast Startup in UEFI settings. Open an elevated command command prompt and type the following commands.

powercfg.exe -h off
shutdown /s /f /t 0

Download Mint Cinnamon. Burn the iso to a DVD. Boot the DVD and wait until you are at the Mint Desktop. Mint runs from RAM and the DVD so it will not touch your Windows install. Attach your 8TB drive. If Mint can mount it a USB icon will appear on the desktop and a File Manager will open showing the drives contents. Click the Computer icon on the desktop. In the lower left pane you will see your Windows drive in GBs. Click on it and another File Manger will open. You can copy and paste between Windows. Or, you could attach another USB external and copy between externals. 

 

SecureBoot needs to be disabled in order to boot Mint and FastStart in order to allow Mint write access to the Windows partition. I have been able to successfully mount drives on linux that failed on Windows. I can't say this will work for you but I think this is the best first step.

 

https://blog.linuxmint.com/?p=3457



#4 DataMedic

DataMedic

    Authorized DataMedic Rep


  • Members
  • 98 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Providence, RI
  • Local time:08:13 PM

Posted 02 May 2018 - 07:35 AM

Please check the external driver properly installed or not else try to use another USB port

Mod Edit:  Post removed, banned spammer - Hamluis.

 

 

 

External HDDs require no additional drivers.


Edited by hamluis, 09 May 2018 - 01:35 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users