Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Just Cause 2 freezes on exit to Windows 10...


  • Please log in to reply
No replies to this topic

#1 Oxonsi

Oxonsi

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Local time:07:23 AM

Posted 22 April 2018 - 02:30 PM

I just started having this issue for no apparent reason.  Just Cause 2 used to work perfectly on my system, including on exit to the Windows desktop.  But not anymore.

 

I haven't had any in game freezes or crashes, although I have not played it extensively recently.  The issue does seem limited to when I exit the game.  And I mean the game freezes with music still playing; the computer / operating system are not frozen.  I am able to ctrl-alt-del, but if I select "Task Manager", it just goes back to an all white or black screen so I cannot make use of Task Manager to terminate the process.  What I generally do is select "Sign out", which does work.  And then when I sign back into Windows, I am brought to the desktop; the game is no longer running.  Otherwise, I'd have to reboot the computer.

 

I have Googled this issue, and I am apparently not alone with this problem.  But I also haven't been able to find any definitive solution to it.  I have tried setting the game to run in compatibility mode for Windows 7, but that has made no difference.  And besides that, it worked perfectly with Windows 10 in the past.

 

I have the latest nVidia drivers for my video card.  I have validated the integrity of my game files, and I have used the Windows system file checker.  I do not seem to have any other problems.

 

Any suggestion on how I might fix this?  I'm not sure what has changed since I used to be able to exit the game.

 

Thanks!


Edited by Oxonsi, 22 April 2018 - 03:42 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users