Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Bay device preventing sleep


  • Please log in to reply
23 replies to this topic

#1 gilittabo

gilittabo

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 03:11 AM

Hi,

 

I am having a problem with trying to get my computer to sleep, it will go to sleep then instantly wake from sleep. My first step was to disable all wake timers, wake from LAN, turned off wake from usb (in windows) and everything else that is possible from my scouring the net. powercfg finds no devices or software from preventing my computer from going to sleep.

 

I have a silverstone FP59 bay device, when it was waking from sleep I noticed that this device would turn off (lights and screen went off) then instantly came back on. I figured that I should check to see if this was the problem so removed the cable connecting it to the usb3 header on the motherboard. When I tried to sleep with it disconnected, sleep worked, Yay!

 

So, what I'm wondering is why does this device wake my computer when it goes to sleep? I have a GA-Z68X-UD3H-B3 gigabyte motherboard, I have tried different bios versions to no success. I have disabled the bay device's drivers in device manager and that didn't work. If anyone knows how to fix this that would be awesome, it's really frustrating. Also, while the computer won't sleep it will hibernate. I don't like hibernating though because I hear it is not good when using an SSD drive.

 

Thanks,



BC AdBot (Login to Remove)

 


#2 xrobwx

xrobwx

  • Members
  • 170 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Panama City Beach, FL USA
  • Local time:10:11 AM

Posted 21 April 2018 - 07:48 AM

https://www.bleepingcomputer.com/forums/t/658164/pc-woke-up-for-no-reason/#entry4342175

 

Thanks goes to jenae for the above possible solution.


Edited by xrobwx, 21 April 2018 - 07:49 AM.


#3 gilittabo

gilittabo
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 07:58 AM

Not going to help I don't think. Apparently nothing should be able to wake my computer. Results from cmd

 

C:\WINDOWS\system32>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

C:\WINDOWS\system32>powercfg -devicequery wake_armed
NONE

C:\WINDOWS\system32>powercfg -waketimers
There are no active wake timers in the system.

:(

 

Edit: Also, the computer will not go to sleep by itself, no mater what sleep time I put on it. Only by manually telling it go to sleep will it actually sleep, but, then wake 1 second later.


Edited by gilittabo, 21 April 2018 - 08:01 AM.


#4 JohnC_21

JohnC_21

  • Members
  • 24,025 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:11 AM

Posted 21 April 2018 - 09:03 AM

I can't say it will work but try the following in order.

 

Disable Fast Startup

 

Open an elevated command prompt and type the following commands

powercfg.exe -h off
shutdown /s /f /t 0

The above disables hibernation. Reboot and see if you can now go to sleep.

 

If not:

 

Did you disable USB Selective Suspend?  This is what you meant when you said you turned off wake from USB in Windows?

I would also set your power configuration to High Performance and see if that helps.



#5 gilittabo

gilittabo
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 09:18 AM

I already had fast startup disabled. I ran your commands and unfortunately didn't work.

 

USB selective suspend is not disabled, though I did have it disabled before it didn't seem to help. With the turning the usbs off in wondows, I meant that I went into device manager and made sure that the USB controllers were unchecked where it said allow device to wake computer, also unchecked keyboard and mouse. I'll try to disable selective Suspend and switch to high performance now and will then report back.

 

update: I'm afraid disabling selective suspend and high performance did not work :( This thing is killing me.


Edited by gilittabo, 21 April 2018 - 09:21 AM.


#6 gilittabo

gilittabo
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 09:22 AM

I have to go to bed now but if there are any more ideas please post them and I'll try them in the morning and post my results. Thanks for the help so far.



#7 JohnC_21

JohnC_21

  • Members
  • 24,025 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:11 AM

Posted 21 April 2018 - 11:36 AM

Does the computer sleep when a USB flash drive is attached to the Bay? Does the computer sleep after doing a clean boot?

 

https://www.windowscentral.com/how-clean-boot-windows-10



#8 gilittabo

gilittabo
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 05:27 PM

Didn't work I'm afraid.

 

I wonder if this is just some built in fault with the motherboard or the bay device that just can't be fixed.



#9 JohnC_21

JohnC_21

  • Members
  • 24,025 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:11 AM

Posted 21 April 2018 - 05:39 PM

Can you RMA the bay? If the new one does the same thing then I would think it was the motherboard. I didn't get a chance to read the MB manual but is there a sleep setting in your BIOS settings? It would be called something like S3.

 

Typing powercfg a at a command prompt will tell you your available sleep states.



#10 gilittabo

gilittabo
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 05:43 PM

Well, I actually have 2 of these bay devices and it happens when I have either one installed. There is a sleep setting in the Bios, it is currently set to S3. powercfg a appears to confirm this.



#11 JohnC_21

JohnC_21

  • Members
  • 24,025 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:11 AM

Posted 21 April 2018 - 06:33 PM

Perhaps is some kind of compatibility problem between the bay and the MB. You disabled allow the computer to turn off this device on all the USB hubs, correct? When you installed the other bay did you also swap out the connecting wires. I can't imagine this would be the problem but it would scratch another item off the list. 

 

Is there anything in the Event logs (System) that points to something? Other than that, that's all I've got, sorry.



#12 gilittabo

gilittabo
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 06:54 PM

Compatibility issue is my fear. Yep that's correct those "allow the computer to turn off this device" checkboxes are unchecked. Yep, I swapped out the cables as well as the device. I've posted event logs below and even if we can't sort this out I really appreciate your help and time, Thank you.

 

________________________________________________________________________

 

Information    22/04/2018 9:46:32 AM    Power-Troubleshooter    1    None

 

The system has returned from a low power state.

Sleep Time: ‎2018‎-‎04‎-‎21T23:46:24.469258000Z
Wake Time: ‎2018‎-‎04‎-‎21T23:46:30.663917400Z

Wake Source: Unknown

______________________________________________________________________________________

 

Information    22/04/2018 9:46:28 AM    Kernel-General    1    (5)

The system time has changed to ‎2018‎-‎04‎-‎21T23:46:28.500000000Z from ‎2018‎-‎04‎-‎21T23:46:26.606118100Z.

Change Reason: System time synchronized with the hardware clock.

__________________________________________________________________________

 

Information    22/04/2018 9:46:26 AM    Kernel-Power    107    (102)

The system has resumed from sleep.

________________________________________________________

 

Information    22/04/2018 9:46:25 AM    Kernel-Power    42    (64)

The system is entering sleep.

Sleep Reason: Application API



#13 JohnC_21

JohnC_21

  • Members
  • 24,025 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:11 AM

Posted 21 April 2018 - 08:10 PM

Perhaps the below link will help. 

 

One interesting command on the page was 

 

powercfg /waketimers

 

https://superuser.com/questions/751544/computer-wakes-by-itself-but-wake-source-is-unknown



#14 gilittabo

gilittabo
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 21 April 2018 - 08:37 PM

No luck. I'm going to give up. It has to be something to do with the motherboard, I'll be upgrading my computer within the next year anyway so I'll just do without the bay device till then. Thanks for the help.



#15 JohnC_21

JohnC_21

  • Members
  • 24,025 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:11 AM

Posted 21 April 2018 - 08:43 PM

Your Welcome, if you do find a solution please post an update. Thanks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users