Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Universal Plug And Play (upnp)


  • Please log in to reply
1 reply to this topic

#1 Jaybird934

Jaybird934

  • Members
  • 110 posts
  • OFFLINE
  •  
  • Local time:11:57 AM

Posted 05 October 2006 - 03:24 PM

After lots of reading I've learned what UPnP is, and how it's NAT traversal enables many common applications to automatically open ports they need, and close them when they're done. (apps like Remote Assistance, Windows Messenger file sharing, various bit torrent clients, etc)

I would like to configure UPnP to work with my Linksys WRT54G V2.2 router (using the latest firmware 4.30.5). I know that it is currently not working because my router is not listed in the "my network places" area in Windows XP, as it should. I also know because several applications that rely on it (such as windows messenger for sending files, or ABC bit torrent client) are not working if the "use UPnP" option is checked. I further know because a UPnP tester I downloaded claims it is "failing". In order to solve the problem I have already taken the following steps:

1) Made sure both the SSDP and the UPnPHost Service are started and running automatically in windows.
2) Enabled UPnP in my router configuration.
3) Reset the router after the firmware upgrade, so that the network may "see" it.

I've researched a lot, and looked all through Linksys's forums, called them, etc. No help. Can someone please clue me in some here? Is there anything else I should do?? I wonder if UPnP is really FULLY supported by my WRT54G v2.2 router? BTW, I do have the "internet gateway" in my network connections area.

thanks in advance, Jb

BC AdBot (Login to Remove)

 


#2 Jaybird934

Jaybird934
  • Topic Starter

  • Members
  • 110 posts
  • OFFLINE
  •  
  • Local time:11:57 AM

Posted 08 October 2006 - 09:01 PM

With absolutely NO help from Linksys, I finally figured it out. In case anyone else should ever need to know, I'll go ahead and answer my own question. Turns out that in order for your router to appear in the "my network places" area it must first send an "I'm alive" message known as a "device description document". When your computer receives this document it will notify you that a new router has been detected (in the same way that conventional plug and play notifies you that it found a new printer)....and then adds a reference to it in the "my network places" area.

But, by default my Linksys WRT54G 2.2 router with the most recent firmware does NOT send this signal. There is no way to turn it on. I changed my firmware to the Hyperwrt Thibor firmware and was happy to see an option to "Send presentation URL" in the UPnP section. Be sure to carefully read the directions for upgrading firmware on the Hyperwrt site. For example, many people do not use the "Clear NVRAM, restore factory defaults" option after upgrading...and this can create problems.

hope this helps someone, Jb




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users