Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Logitech Webcam C930e Driver issue (code 19) on Win 10 LTSB


  • Please log in to reply
No replies to this topic

#1 At0mX

At0mX

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Abidjan
  • Local time:05:13 AM

Posted 10 April 2018 - 08:45 PM

Hello Everyone, first time here.   
Here is my problem: I just bought a Logitech C930E HD Webcam and I can't get it to work on my windows 10 LTSB: I'm getting a Code 19 Error:

"Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. To fix this problem you should uninstall and then reinstall the hardware device. (Code 19)"

I have the feeling that the initial driver that the Device Manager downloaded from the internet through Windows Update either is bugged or wasn't installed correctly and using an older driver doesn't replace ALL the bugged 'recent' drivers.

I don't know if the fact that I'm using a LTSB Windows 10 edition (Ver 1607) changes anything.

Please see attached pictures and USBTree output.
Attached File  1.png   232.85KB   0 downloadsAttached File  Event 420.png   85.78KB   0 downloadsAttached File  Event 430.png   107.38KB   0 downloadsAttached File  Event 20001.png   89.8KB   0 downloadsAttached File  Event 20003.png   95.22KB   0 downloadsAttached File  win10.png   537.61KB   0 downloadsAttached File  6.png   358.92KB   0 downloadsAttached File  Logitech USB Camera (Webcam C930e).txt   257.91KB   0 downloads

What has been tried:   
- change USB port  
- rebooted   
- tried the webcam on a macbook pro => OK    
- install older driver (downloaded from internet)   
- UpperFilters and LowerFilters Registry trick

What do you think or recommend?

Thank you

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users