Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Error in Fixing Windows Update Freezing


  • Please log in to reply
2 replies to this topic

#1 dmakexmachina

dmakexmachina

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:01:52 AM

Posted 07 April 2018 - 04:40 PM

Hi everyone,

 

I am posting about an issue I am having with a windows 10 update that will freeze at around 85% requiring me to restart the computer. After restarting, the computer would attempt to recover the installation, fail, and restore itself to the previous version of windows, which starts the whole cycle over again. I originally posted about this in the BSOD & Hangs section of the forum, but I saw a few posts here about the same issue, so I thought I would try this part of the forum.

Here is a link to my previous post, which provides more information about the problem and fixes I have tried: 
https://www.bleepingcomputer.com/forums/t/674394/windows-10-computer-freezes-during-updates/

 

I came across another post here that had a similar issue and included in that was a document detailing a fix for stuck Windows 10 updates (which I am attaching to my post as well).

 

I got to this point of the instructions 

 

Now lets pullout with DISM.exe the list of installed packages

At the D:\> prompt type:-

dism /image:D:\ /get-packages (press enter)

But when I tried to execute that command I got this as an error

 

Deployment Image Servicing and Management tool

Version: 10.0.14393.0

 

Error: 1639

 

The command-line is missing a required servicing command.

For more information, refer to the help by running DISM.exe/Image=<path_to_offline_image> /? where <path_to_the_offline_image> is the full path to an offline Windows image.

 

The DISM log file can be found at X:\windows\Logs\DISM\dism.log

 

I'm not sure what to do from here or really if this is the right solution to my particular problem anyway. Can anyone help me out? Thanks!

 

 

 

Attached Files



BC AdBot (Login to Remove)

 


#2 jenae

jenae

  • Members
  • 607 posts
  • ONLINE
  •  
  • Local time:04:52 PM

Posted 07 April 2018 - 07:02 PM

Hi, unusual not seen this before, you are in the RE and you have used the bcdedit |find "osdevice" cmd to establish D: drive has the OS? When you get to the cmd 

 

 

dism /image:d:\ /get-packages, input this cmd instead:-

 

 

dism /image:D:\ /get-packages /scratchdir:D:\temp (press enter)

 

If this fails you have lucked out, the "Spring" update is due in days you can download this it should get you going.



#3 dmakexmachina

dmakexmachina
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:01:52 AM

Posted 07 April 2018 - 11:23 PM

Turns out I had missed the space between "\" and "/" in the command line. Now though I am looking at the packages list and it is saying that all of them are installed, but it is also saying that this occurred yesterday. It does not seem to have the current Fall Creators Update, which is what my computer is attempting to install, which I downloaded and prepared earlier today.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users