Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Win Problems


  • Please log in to reply
13 replies to this topic

#1 GSGregg

GSGregg

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pasadena, CA.
  • Local time:12:27 AM

Posted 06 April 2018 - 02:58 AM

Mod Edit:  Split from https://www.bleepingcomputer.com/forums/t/428847/cant-save-in-notepad/ - Hamluis.

 

Hello, Hamluis, et al;

 

I finally ditched XP with this refurbished HP Desktop with W7-64, SP1; after blocking a Notepad doc to fit between the sides of my display, I can't close the "Save As" window...I saw the above post about removing the asterisk from the .txt extension, but except for adding or removing highlight, I can't affect the text on the 'Save As Type' line. (No such problem with the File Name line...) I suppose I'm overlooking something absurdly fundamental  :unsure:

 

System File Checker seems like overkill on a PC I've had only two weeks...Thanks;

 

Gregg


Edited by hamluis, 06 April 2018 - 02:18 PM.


BC AdBot (Login to Remove)

 


#2 opera

opera

  • Members
  • 981 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:27 AM

Posted 07 April 2018 - 12:44 AM

When you do 'Save as file type' don't try to type anything in, instead go to the far end of that box where there is a little black arrow. Press it and select 'all files'

 

Is that what you mean?



#3 joseibarra

joseibarra

  • Members
  • 1,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:03:27 AM

Posted 07 April 2018 - 04:28 AM

Since the crystal ball is on the fritz and only being able to imagine what you are seeing...

 

That's right.  In Notepad you can't "affect the text on the 'Save As Type' line.

 

You can't make any changes to the Save as type field in Notepad - which is just a simple text editor:

 

 

Perhaps if you describe the problem and include some details of how you think you might like it to work you will get some ideas.

 

If you could change the Save as type what would you want to change it to and why?

 

There are lots of better free Windows compatible text editors depending on what you want to do...  like notepad++

 

https://notepad-plus-plus.org/

 


The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#4 GSGregg

GSGregg
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pasadena, CA.
  • Local time:12:27 AM

Posted 15 April 2018 - 10:34 AM

To opera and joseibarra; sorry about taking 8+ days to respond...for some reason, email notifications have been hit-or-miss, and this time around, they missed.

 

As I mentioned in my OP, I finally 'ditched XP' a few months ago (actually, XP ditched me when my ATX tower's motherboard finally gave up after being progressively weirder for over a year) and after almost 9 years with Old Faithful, the inevitable differences in Win7, while subtle, are enough to have me staring like a deer in headlights - and since XP won't boot up, I can't utilize side-by-side comparison to get myself over the hump...

 

My bit about affecting the text is based on a reply, to the topic from which I was moved, in which the poster said that all he had to do was "remove the asterisk" from in front of the dot-text extension (*.txt) - which I tried, but was unable to do. I should add that I tried everything I could reach or yell at, and finally got whatever document it was to Save...but I don't recall what I did.

 

Anyway, the four screenshots below show what I'm running into:

 

Attached File  CantSave_1.jpg   135.14KB   0 downloadsAttached File  CantSave_2.jpg   155.64KB   0 downloadsAttached File  CantSave_3.jpg   173.37KB   0 downloadsAttached File  CantSave_4.jpg   119.62KB   0 downloads

 

It stands to reason that if I do anything but click Save or Yes, I'll get nowhere, so...

 

...and when I close out the message box(?), the cycle begins anew.

 

Any insight will be greatly appreciated, and to Bill...

 

Ack! (Thanks!)

 

 



#5 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,550 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:08:27 AM

Posted 15 April 2018 - 05:28 PM

Your last screen - Access denied - suggests that this file is either read only or in a folder marked read only.

 

Just as a test I have just found a .INI file in my Windows folder (Win7), opened it in Notepad and 'Saved as' the same file name to a temp folder on my C:\ drive. And all I had to do after I had pointed it at the temp folder was click on 'Save'. The name of an existing file which you are editing will appear as the file name in the filename box, you only have to change the '*.txt' bit if you are creating a new file, say you you have just quickly copied some text which you want to keep for a short period while you do something else.

 

But if you are editing an existing file in notepad, just click 'Save'.

 

Chris Cosgrove



#6 joseibarra

joseibarra

  • Members
  • 1,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:03:27 AM

Posted 16 April 2018 - 02:14 AM

I suggest you make a few adjustments to the way Explorer displays files so you can see the file extensions and all see hidden/system files - then you will be able to better see what is in that folder.

 

Later if you find the adjustments cause too much clutter in your view of folders you can undo the adjustments.

 

With Windows Explorer open click Tools, Folder Options, View tab and make it look like this:

 

 

Then you should see that there are some files in that folder with a .ini extension (normally hidden extensions).

 

Are you trying to replace the pinemhi_leaderboard.ini in that folder?

 

If that file already exists right click it, Properties and if it is read only you should clear the read only checkbox for the file, then see about replacing it:

 


The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#7 GSGregg

GSGregg
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pasadena, CA.
  • Local time:12:27 AM

Posted 16 April 2018 - 09:38 AM

Just as a test I have just found a .INI file in my Windows folder (Win7), opened it in Notepad and 'Saved as' the same file name to a temp folder on my C:\ drive.

Did you make any changes before closing, prompting the machine to ask if you wanted them saved? In this instance, under the bracketed [path], I changed the four Drive letters from C:\ to F:\, as this former main harddrive is now in a USB external enclosure. When I am more comfortable with 64-bit filing protocol(?), I may transfer (Copy/Paste) everything to the current C:\ drive and relegate F:\ to backup.
 

And all I had to do after I had pointed it at the temp folder was click on 'Save'.

 That;s what I expected; since the filename was not being changed and the file was going back into its original folder automatically, a single click on 'Save' should have completed the operation without my having to 'point it' anywhere. If I had created or modified the filename, then I can see an extra 'Save' being necessary (my above screenshot #2).
 
Maybe I'm not through with XP after all, and I should build a double-boot machine...
 

The name of an existing file which you are editing will appear as the file name in the filename box, you only have to change the '*.txt' bit if you are creating a new file...but if you are editing an existing file in notepad, just click 'Save'.

 Sounds right to me...
 

With Windows Explorer open click Tools, Folder Options, View tab and make it look like this:

Never found Tools, but finally got Folder Options from Control Panel; they were set pretty much as you suggested, except for protected OS files being hidden. The PinemHigh_1_5 folder is a Program Files constituent, as is the Visual Pinball folder which contains, among other things, the VPinball and VPinball990 EXEs; hopefully, none of them qualify as  protected files for our purposes...
 
Also, the Read-only attribute was / is not checked.
 

Are you trying to replace the pinemhi_leaderboard.ini in that folder?

If it's wrong to consider this a simple Edit, then, yes - I want to replace the UNchanged file with the changed file.



#8 Papakid

Papakid

    Guru at being a Newbie


  • Malware Response Team
  • 6,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:27 AM

Posted 16 April 2018 - 04:49 PM

Hi GSGregg,

 

It took a bunch of reading and rereading to figure this out, but I think I know now what the original poster was talking about in regards to the asterisk.  He was creating a new file from scratch.  When you do that, the File name field will have *.txt entered in automatically--sort of a placeholder and example of a file name.  So he just entered a file name to solve his problem, he didn't change the asterisk in the Save As Type menu--which can't be done as you've been finding out.  It's a menu not a text field.

 

So what you are trying to accomplish is to save an .ini file that you've edited, without changing the file name.  Correct?  Did you change the Save As Type to All Files?  If so and it doesn't work, what happens next?  It should be that if you leave the Save As Type to *.txt it will save as a .txt file instead of an .ini file.


Edited by Papakid, 16 April 2018 - 04:51 PM.

The thing about people

is they change

when they walk away.--Mipso


#9 GSGregg

GSGregg
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pasadena, CA.
  • Local time:12:27 AM

Posted 17 April 2018 - 08:41 AM

Hello, Papakid;

 

When I tried to Save as type: All files (*.*), I got the same 'Access Denied' box from before, and when I closed it out, the Save As File Type box reset to (*.txt). I then looked into Security, Ownership, Permissions et al, but didn't pursue anything due to total inexperience in the matter. I eventually came across this about a Windows Hidden Administrator Account:

 

https://answers.microsoft.com/en-us/windows/forum/windows_7-security/access-denied-need-permission-to-save-a-simple/c6ae0c54-4498-45a0-a89e-8c9906d8f242

 

Do you think this might be what I'm after? Thanks;

 

Gregg



#10 Papakid

Papakid

    Guru at being a Newbie


  • Malware Response Team
  • 6,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:27 AM

Posted 17 April 2018 - 11:32 AM

It's possible, just seems to me to be too much sugar for a dime.  Plus that is for saving a text (*.txt) file.  I researched possible solutions to saving an .ini file and see some things that might be a bit simpler.  It appears the problem is the Program Files folder is considered a system folder and as such is restricted.  It might be as simple as changing system files to unhide them as suggested previously but that you were hesitant to do.  You can also try this:  when you open the .ini file, right click and choose Run as administrator

 

This last suggestion seems to work most times for people editing .ini files--move the .ini file to your desktop folder, edit and save it there, then move it back to where you want it.  There is something else that might work but is more involved.  Let me know how it goes before we do that.


The thing about people

is they change

when they walk away.--Mipso


#11 GSGregg

GSGregg
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pasadena, CA.
  • Local time:12:27 AM

Posted 18 April 2018 - 03:46 AM

...that is for saving a text (*.txt) file.  I researched possible solutions to saving an .ini file and see some things that might be a bit simpler.

Good. I'm far from a proficient typist, and spend as much time spellchecking errant keypresses as I do command-prompting  :oopsign:  
 

It appears the problem is the Program Files folder is considered a system folder and as such is restricted.  It might be as simple as changing system files to unhide them as suggested previously but that you were hesitant to do.

Referring to my original setting of hiding protected System files? I don't know how I overlooked that; as this is the only computer (no network) and I am the only operator, I've always left that unchecked... 
 

You can also try this:  when you open the .ini file, right click and choose Run as administrator.

Run as Administrator is not included in the right-click menu for the .ini file, but I have seen Run as Administrator specified when opening Notepad proper - I guess the file needs to be imported / exported in that case.
  

This last suggestion seems to work most times for people editing .ini files--move the .ini file to your desktop folder, edit and save it there, then move it back to where you want it.  There is something else that might work but is more involved.  Let me know how it goes before we do that.

Is this one of the simpler things you encountered? It mentions a few of your pointers...

 

https://www.sevenforums.com/general-discussion/204784-access-denied-when-editing-ini-files.html

 

If I don't wind up falling asleep, I'll give it a try.

 

Gregg

 

EDIT: I couldn't Run as Administrator,because, as I said, the option doesn't show up in the right-click menu; not even when the .ini is opened from the desktop. And when I tried to overlay the edited file on the file icon in the pinemhi_1_5 folder, there was no Paste option in the right-click menu. (Growl)
 


Edited by GSGregg, 18 April 2018 - 06:38 AM.


#12 Papakid

Papakid

    Guru at being a Newbie


  • Malware Response Team
  • 6,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:27 AM

Posted 18 April 2018 - 11:42 AM

Unhiding OS files is probably not so simple a fix, but always willing to try simple first. Not sure how you missed it either, but you told joseibarra in Post #7 that his suggested folder options setting had already been done except for Operating System files. You seemed to think it unnecessary, and it may be, but you could try it for a time while troubleshooting, then change it back. My personal preference, born of years working in malware removal, is to keep these files unhidden, but that is not the right choice for everyone.

 

Yes, the page you linked to is one that I looked at but not all.  I like to find two or three threads or pieces of relevant info when researching suggestions on things I haven't done myself--and when possible or at least partially convenient, I try to reproduce or follow instructions myself to see if they work--but haven't done that in this case because I can't think of a way to reproduce what your ultimate goal is.

 

 

EDIT: I couldn't Run as Administrator,because, as I said, the option doesn't show up in the right-click menu; not even when the .ini is opened from the desktop. And when I tried to overlay the edited file on the file icon in the pinemhi_1_5 folder, there was no Paste option in the right-click menu. (Growl)

First, I prefer that you not edit your post when giving feedback on what works/didn't work or if relaying important info.  That's because I have my email notifications set to include the post contents when you reply.  Thus I might begin researching what to do before actually coming back to the thread--sometimes making all the research in vain when new info is added.  That wasn't the case here and it really isn't a big deal but just wanted you to know there is really no problem with making a new post when you have info of significance--moderators can tell that you aren't flood posting.

 

So you were able to save the modified .ini while it was on your desktop but now you can't get it back in the pinemhi_1_5 folder?  Have you tried drag and drop?  If that doesn't work, try moving the old .ini file out of the pinemhi_1_5 folder and see if the edited one will move.

 

The more involved thing I mentioned trying really isn't too complicated, just a bit more to it than what we've tried so far.  That is the solution posted by the OP in the thread you just linked to.  Try toggling UAC off and on.  Go to Control Panel (set it to large icons instead of category), open Action Center, click Change User Account Control settings, then move the slider all the way to the bottom to Never.  To re-enable, put it back to where it was.  Reboot after each change.  I would try it both ways.

 

If none of these suggestions help, we might try taking ownership of the program files folder, but i want to research that a bit more to know what are the consequences of such a change.

 

I suppose you have a good reason but I have to ask anyway--can you not just reinstall the program in question and point it to your F drive--or the standard program files on C: for that matter?  That way you wouldn't have to modify the file path in the ini file.

 

 

 

 


The thing about people

is they change

when they walk away.--Mipso


#13 GSGregg

GSGregg
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pasadena, CA.
  • Local time:12:27 AM

Posted 23 April 2018 - 11:03 AM

Sorry for being absent, Papakid;  a few non-computer things needed attention.

...when possible or at least partially convenient, I try to reproduce or follow instructions myself to see if they work--but haven't done that in this case because I can't think of a way to reproduce what your ultimate goal is.

Any goal would be far less lofty than I made it seem. With four harddrive failures since Feb of 2011, I've transferred files a few times...always from a C:\ drive to a replacement C:\ drive, always by Copy and Paste (highlight, in turn, the entire contents of C:\, Program Files, My Documents, My Pictures, etc, and let 'em rip - later running / installing and/or redownloading whatever needed to be) and  never concerned with permissions on 32-bit XP. When that 2008 desktop recently gave up, and Firefox finally dropped XP support, I bought this refurbished HP Compaq Elite 8000 SFF with Win7x64 and wasn't sure how much of a pain the newer technology would give me.

 

This hunt for administrative permissions has certainly qualified...
 

EDIT: I couldn't Run as Administrator,because, as I said, the option doesn't show up in the right-click menu; not even when the .ini is opened from the desktop. And when I tried to overlay the edited file on the file icon in the pinemhi_1_5 folder, there was no Paste option in the right-click menu. (Growl)

I had no trouble copy-and-pasting this time, so previously must have been working the wrong file, or something...

So you were able to save the modified .ini while it was on your desktop but now you can't get it back in the pinemhi_1_5 folder?  Have you tried drag and drop?

Sure did - and it turns out that both drag-and-drop and copy-paste work interchangeably. The real key to permissions is the Destination Folder Access Denied message box; once you've gotten that far, clicking Continue concludes the operation.
 

I suppose you have a good reason but I have to ask anyway--can you not just reinstall the program in question and point it to your F drive--or the standard program files on C: for that matter?  That way you wouldn't have to modify the file path in the ini file.

I don't know that I have a reason, especially in view of how much time has been wasted, but it's nice to finally know that it can be done in a few minutes instead of hours. if there's a next time...

 

1) With containing folder open, drag-n-drop or copy-paste target file from folder to desktop

 

2) Open target file on desktop; edit and close, bringing up the Notepad dialog box: "Do you want to save the  changes...?" (1st screenshot)

 

3) Click Save; containing folder regains focus

 

4) Drag-n-drop or copy-paste edited target file from desktop back to containing folder, bringing up the Copy File box: "There is already a file with the same name in this location. Click the file you want to keep." (2nd screenshot)

 

5) Click Copy and Replace, bringing up the Destination Folder Access Denied message box: "You'll need to provide administrative permissions to copy to this folder." (3rd screenshot)

 

6) Click Continue and you're finished. If desired, delete extra file copy from desktop.

Attached File  CantSave5.jpg   135.98KB   0 downloadsAttached File  CantSave6.jpg   210KB   0 downloadsAttached File  CantSave7.jpg   188.06KB   0 downloads

 

Moderator; Anything incorrect or unsuitable? Please correct or enhance



#14 Papakid

Papakid

    Guru at being a Newbie


  • Malware Response Team
  • 6,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:27 AM

Posted 24 April 2018 - 11:52 PM

Thanks for posting back, Gregg, and glad you had success.  Not sure why it works for you now when it didn't the first time, but happy that it does.  As for lofty goals, perhaps I should reword what I mean--by "ultimate goal" I just mean what are the end results you are trying to achieve.  You have been able to edit and save your .ini file to its proper folder, correct?  Then beyond that you want to be able to run the program.  So are you going to leave it on the external F: drive?

 

I think the higher restrictions are the difference between XP and Windows 7, not because your computer is 64 bit.  Windows 7 has the same security enhancements (compared to XP) in 32 and 64 bit.  To install and run 64 bit programs you mostly only have to be concerned with making sure you install 64 bit versions.  Altho, as you may have noticed, there is a Program Files (X86) folder in Win7 for 32-bit applications in addition to the normal Program Files folder that existed in XP.  The ins and outs of all of this I don't know much about since I am "coding challenged".  I just install and let Windows take care of most of where to put the files (under normal circumstances).  But I see by the nature of the program you are dealing with that you may know more about such things than I do.  I.E., 64-bit is more of concern for those who write and manipulate software than it is for those of us that just operate a computer.

 

The real key to permissions is the Destination Folder Access Denied message box; once you've gotten that far, clicking Continue concludes the operation.

Don't know if I would word it quite this way.  I see this more of a roadblock to continuing (or in this case concluding) the process of achieving your end result.  Since it implies that you need to back up and go thru some other process to get admin permissions, instead of just clicking Continue and being done with it.  Why Microsoft thought it necessary to say Boo! here then smile and open the door I have no idea.  But thanks for the steps you've written out and the screenshots--we should note that the Destination Folder Access Denied message box is different here than Notepad's Access Denied box screenshot in your post #4.

 

I think the "real key" to permissions we've encountered here is who has ownership of what folders.  The reason editing a system file on the desktop works is because, in Windows 7, the desktop is a subfolder of your user account and you have ownership of everything in C:\Users\(YourAccountName).  You probably could have moved the .ini file to your My Documents, My Pictures or similar library folders and been able to edit it.  Any other personal user accounts on the computer will be locked out of your account folder--Access Denied.  The Program Files folder is owned by the System user account, thus your lock out and Access Denied message in Notepad.  So if in future, you want to edit something in Program Files, research how to take ownership and I think you'll be fine and have less hassles.

 

If you have any other problems getting your program up and running, let us know.  I'm tempted to explore it myself--if I had the time--since I was a big pinball/arcade game junkie back in the seventies and early eighties.


The thing about people

is they change

when they walk away.--Mipso





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users