Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Port forwarding trouble - the port is occupied


  • Please log in to reply
2 replies to this topic

#1 MrSparrow

MrSparrow

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:07:33 AM

Posted 05 April 2018 - 09:50 AM

Hi! I was just trying to forward a  single port in my router for TCP and UDP. Now all the tutorials I read so far in the internet (via google :whistle: ) mentioned that either under Port Forward/Virtual Server setting page there should be an option like 'Tcp - UDP - Both' and in that case I've to select both or if there isn't any 'Both' option then I've to make two entries- one for TCP and another for UDP accordingly.

My problem is in my router there is no 'Both' option for TCP and UDP. So I assume that I've to make two entries, one each for TCP and UDP. But after making the first entry, be it TCP or UDP, with a static ip I've already set, the second entry I'm trying to make for the same port says that 'The port is occupied'. So I am unable to make the other entry as those tutorials explained must for a P2P client to work properly. But how can I do so here? Below is the screenshot of my port forwarding setting page-

24zcd4m.jpg

I didn't delve into the router hardware, fw version, os name, ram etc as I think is not so important here to understand and answer my problem. I already set a static up in router. Can make one either TCP or UDP port forwarding rule in there. But then I'm stuck and really need your expertise to solve the mystery and have a workaround to the problem as how to make the second entry for the tcp or udp???

I've two more things to ask though- what is the difference here as WAN port and LAN port mentioned above in the page? I know that I've to put there the same port number in both blanks which I want to forward (correct me if I'm wrong here) but still what's the difference? I thought I was forwarding WAN port then why I've to fill the LAN block too?

And second, is NAT port triggering can be of any help here? Read couple of explanation about the difference between port forwarding and port triggering but it still confuses me!

Anyone care to help me out here? :(



BC AdBot (Login to Remove)

 


#2 MrSparrow

MrSparrow
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:07:33 AM

Posted 07 April 2018 - 01:47 AM

No one have any suggestion on this matter??? :o

 

Bytheway...I posted the default picture earlier...so I'm updating it now-

 

30cahrs.jpg

You can see I'm trying to forward "50123" port, TCP protocol (for example) for a P2P application. After saving it I can't make the UDP protocol with the same port and ip number as router says - "This port has been occupied".

All the tutorials I've seen, some of the router shown there, have the 'BOTH' option in Protocol, but I don't have it. That's why I was trying to make two entries one for TCP and then the next for UDP. But I'm stuck!

 

Any HELP?? PLEASE!! :(


Edited by MrSparrow, 07 April 2018 - 01:58 AM.


#3 Cyanogen

Cyanogen

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:03 PM

Posted 09 April 2018 - 09:11 PM

Sparrow,

 

Before all... try rebooting the hardware :)

 

Keep the protocol TCP.

 

Could you specify the make (not model) of your router?

 

Try forwarding to a known port like 80, 443, 21, etc, and see if it gives you the same output.

 

If it does, try forwarding a known non-existent port like 65536 and see if it gives you the same output.


Edited by Cyanogen, 09 April 2018 - 09:12 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users