Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Using Metered Connection to stop auto updates not working


  • Please log in to reply
10 replies to this topic

#1 jmbtexas

jmbtexas

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:10:34 PM

Posted 27 March 2018 - 01:19 AM

Hi,

 

I have my laptop set to metered connection on both the Wifi and Ethernet, but Windows 10 is still installing updates without my approval.  I did the same thing on my desktop, and Windows 10 will not install updates without my approval.

 

Any ideas on why this is happening on my laptop?

 

Thanks!



BC AdBot (Login to Remove)

 


#2 Mason21

Mason21

  • Members
  • 418 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:10:34 PM

Posted 27 March 2018 - 04:47 AM

Do you have Windows 10 Pro or Home?



#3 jmbtexas

jmbtexas
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:10:34 PM

Posted 27 March 2018 - 08:40 AM

Do you have Windows 10 Pro or Home?

 

Hi, I have Windows 10 Home on both machines.



#4 Mason21

Mason21

  • Members
  • 418 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:10:34 PM

Posted 27 March 2018 - 02:45 PM

        Keep in mind disabling Windows Update is not really a wise move. 



#5 jmbtexas

jmbtexas
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:10:34 PM

Posted 27 March 2018 - 10:57 PM

I appreciate the video, but I am not very interested in disabling and enabling Windows Update that way every time I want to get updates.

 

I would really like to know why setting my laptop to a metered connection is not preventing Windows from automatically installing updates like that option does on my desktop.

 

Thanks



#6 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,294 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:11:34 PM

Posted 28 March 2018 - 09:50 AM

Are you certain that the laptop is connected only to the metered connection at at all times?   That's the only way you can make that trick work.

 

If the laptop is mobile and you connect to other WiFi or ethernet connections that are not marked as metered they updates will immediately download on the next check.

 

Also, if you're only using the laptop at home go in to your WiFi connections and make sure to "forget" everything except the metered connection.  This will prevent any accidental connecting to another WiFi network (like a neighbor's open network if your own flakes out).


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1809, Build 17763 

     Presenting the willfully ignorant with facts is the very definition of casting pearls before swine.

             ~ Brian Vogel

 

 

 

              

 


#7 jmbtexas

jmbtexas
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:10:34 PM

Posted 28 March 2018 - 04:03 PM

Are you certain that the laptop is connected only to the metered connection at at all times?   That's the only way you can make that trick work.

 

If the laptop is mobile and you connect to other WiFi or ethernet connections that are not marked as metered they updates will immediately download on the next check.

 

Also, if you're only using the laptop at home go in to your WiFi connections and make sure to "forget" everything except the metered connection.  This will prevent any accidental connecting to another WiFi network (like a neighbor's open network if your own flakes out).

 

Laptop is only hardwired at home, but I do use Wifi at work.  Next time I'm in the office, I will make sure to check that setting as well...although I know this issue is happening when I am at home with Wifi turned off (on the computer).   Thanks!



#8 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,294 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:11:34 PM

Posted 28 March 2018 - 05:44 PM

Well, it will happen at home if the update(s) are downloaded over WiFi [which had not been marked as metered] when you were at work.

 

Since Windows uses "active hours" to determine when an update that requires a restart will apply, you need to check that, too.  I also turn on the "Show More Notifications" option on in the Restart Options under Windows Update so that I get a warning well before a restart.

 

Remember, once an update is downloaded you can postpone it, but only for so long (Home) or so many times (Pro).

 

I haven't checked in ages, but have they added a metered option for ethernet connections?  That didn't exist for a very long time and I'd heard it was coming, but not that it had arrived.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1809, Build 17763 

     Presenting the willfully ignorant with facts is the very definition of casting pearls before swine.

             ~ Brian Vogel

 

 

 

              

 


#9 xrobwx

xrobwx

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Panama City Beach, FL USA
  • Local time:10:34 PM

Posted 29 March 2018 - 11:58 AM

Also, does that setting to allow updating other computers on your network and from other sources override the metered selection?

Attached Files


Edited by xrobwx, 29 March 2018 - 12:04 PM.

7581204627.png


#10 dmccoy

dmccoy

  • BSOD Kernel Dump Expert
  • 1,195 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:34 PM

Posted 04 April 2018 - 07:21 PM

As mentioned if you are using your metered setting with ethernet it will not work. To enable this option see the link below.

 

https://www.windowscentral.com/how-set-ethernet-connection-metered-windows-10

 

Another method that I prefer is the following tool:
 

Windows Update Minitool

http://www.majorgeeks.com/files/details/wumt_wrapper_script.html


We are all volunteers so please by kind, courteous and respectful

 

I try to respond in 24-48 hours normally and I am more active on weekdays than weekends. However, sometimes due to my health, family or life it may take me a little longer. If you have not heard from me within 72 hours then please PM me a reminder. 

 

BC BSOD Posting Instructions 


#11 jenae

jenae

  • Members
  • 882 posts
  • OFFLINE
  •  
  • Local time:03:34 PM

Posted 05 April 2018 - 02:07 AM

Hi, you should not change permissions on that registry key, ( and you would have repair network issues if you needed to do so in the future "access denied", that's just poor advice from that site)  and you don't need to. Windows ten added metered connections for ethernet as well as wifi, from version 1703 upwards, use pc settings, network & internet, click on ethernet, then on your ssid (connection) under this you can set ethernet as metered.

 

The registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\DefaultMediaCost, already exists, the value data setting is 1 for off and 2 for on.

 

 

Edit:- a network reset or fresh connection can change this setting, so it is valid, to check if yours is effected, if you are experiencing problems, 


Edited by jenae, 05 April 2018 - 02:12 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users