Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't open Music folder sitting in my user profile


  • Please log in to reply
18 replies to this topic

#1 JohnDohe

JohnDohe

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 21 March 2018 - 07:01 PM

System:
Win7 Pro, ASUS B35M-E motherboard, 16GB ram, one 256GB SSD and one 1-TB HDD.

I just finished doing a clean install of Win7 Pro.

I successfully moved my Desktop, My Music, My Videos to my D-data drive from their
default location in C:\Users\(username).

But there's this one folder, Music, in my user profile in C:\Users\(username) that I can't
even open.  

I've tried all the permission, ownership, auditing etc., tricks under
Properties >Security tab >  Advanced
that I know of and am able to do, to no avail.  Access denied . . . Access denied is what
I get when I try to change Owner, Permissions, Auditing . . . I've even tried a couple of
those context menu "Take Ownership" utilities with no success.

 

Attached File  Can't open Music folder under user profile.PNG   74.91KB   1 downloads

 

Attached File  Unable to set new owner on Music - access denied.PNG   47.48KB   0 downloads

Anyone got any idea what this Music folder is and why I can't get into it?

Do I need it?

Can I get rid of it?

Thanks!



BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,131 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:53 PM

Posted 22 March 2018 - 07:47 AM

Seems possible that you did not properly move the Music folder, located at that path...and Windows decided to create a default folder.

 

https://www.howtogeek.com/howto/windows-vista/moving-your-personal-data-folders-in-windows-vista-the-easy-way/

 

Since you fooled around with permissions...I cannot guess how that may impact the ability to access various files/folders.

 

Louis



#3 JohnDohe

JohnDohe
  • Topic Starter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 22 March 2018 - 09:23 AM

"fooled around" ??

 

What kind of reply is that?

 

Helpful?

 

Hardly.

 

You mock me.

 

First of all I did not "fool around" with anything.  I followed instructions and its pretty

slam-dunk simple to change the default location of a folder in one's User profile. 

The ability to do so is specifically provided for right in the folder's properties.

 

Should I report you for abuse?



#4 JohnC_21

JohnC_21

  • Members
  • 24,311 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:53 PM

Posted 22 March 2018 - 09:53 AM

I think the Music folder under USERS is a pointer to your My Music folder on the D: partition but I could be wrong. This is why Windows is not allowing access. If you allow System Files to be shown you will see a Documents and Settings folder which is also a pointer. Double clicking on it will also give you an access denied.

 

Than being said. Open an elevated command prompt in DOC. Use the icacls command shown in the below link to reset the permissions in Music. This may or may not work.

 

https://stackoverflow.com/questions/22327776/using-icacls-to-set-permissions-of-a-folder-to-inherit-recursively

 

An additional link to show the specific switches of icacls.

 

https://ss64.com/nt/icacls.html



#5 JohnDohe

JohnDohe
  • Topic Starter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 22 March 2018 - 10:04 AM

"icacls" ?

 

Over my pay grade!  :mellow:

 

Could you provide step-by-step instructions?

 

I went to the link you provided, but again, its written in geek

which I don't speak!

 

I'm not a formally trained tech, just a lonely doctor trying to

keep up in this tech world.

 

BTW here's what I get when I try to delete the Music folder.

 

Also note that the Music folder does not have any sort of hyperlink

icon associated with itself:

 

Attached File  Can't delete Music folder in User Profile.PNG   78.86KB   0 downloads

 

All help is much appreciated!

 

Thanks!


Edited by JohnDohe, 22 March 2018 - 10:22 AM.


#6 JohnC_21

JohnC_21

  • Members
  • 24,311 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:53 PM

Posted 22 March 2018 - 10:16 AM

Personally I would leave the Music folder. 

 

Open an elevated command prompt. Type CMD in the search box Right click and select Run as Administrator.

 

This will give you a prompt of C:\Windows\System32.

 

At the command prompt type 

 

cd c:\users\doc

 

This should give you a command prompt of C:\USERS\DOC

 

At this command prompt type: 

icacls "Music\*" /q /c /t /reset

I can't say this will work if the folder is a pointer. 

 

If you want to see what is in this folder you could boot a live linux disk and browse to the folder. Linux doesn't care about Windows Permissions. You could do this first and if Music is empty that would tell you it's a pointer.



#7 JohnDohe

JohnDohe
  • Topic Starter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 22 March 2018 - 10:25 AM

@ JohnC_21

 

Thanks for the detailed instruct!

 

Here's what happened:

 

Attached File  Can't delete Music folder in User Profile using icacls elevated command prompt.PNG   12.16KB   0 downloads

 

What to do?

 

Thanks!



#8 JohnC_21

JohnC_21

  • Members
  • 24,311 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:53 PM

Posted 22 March 2018 - 10:36 AM

You can attempt to take ownership of the folder then use the icacls command. If that fails then I am out of ideas.

 

Open an elevated command prompt type the same commands to get to a c:\users\doc command prompt. Type the following command

takeown /f Music /r /d y

Then use the same icacls command in the previous post.



#9 JohnDohe

JohnDohe
  • Topic Starter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 22 March 2018 - 10:51 AM

Hi,

 

Well, tried to take ownership using your instruct:

 

Attached File  Can't delete Music folder in User Profile take ownership via command prompt denied.PNG   11.52KB   0 downloads

 

I really appreciate you getting back to me so quickly.

 

I know you say you're tapped as to what to do now, but if you do think of something let me know!

 

Thanks!



#10 JohnC_21

JohnC_21

  • Members
  • 24,311 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:53 PM

Posted 22 March 2018 - 10:58 AM

Your Welcome.

Yeah, I would say just leave it unless you really want to see what is inside. I know linux could delete this folder but if you did that I think your pointer to My Music in D: would be borked.



#11 JohnDohe

JohnDohe
  • Topic Starter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 22 March 2018 - 11:01 AM

". . . pointer to My Music in D: would be borked."

 

Hmmm, but the Music folder doesn't have any kind of shortcut little curved arrow.

 

To me that says that there's no hyperlink to anywhere else.

 

Am I wrong?



#12 JohnC_21

JohnC_21

  • Members
  • 24,311 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:53 PM

Posted 22 March 2018 - 11:11 AM

Not Necessarily. If you allow System Files to be shown Documents and Settings will also give you an accessed denied but that folder would have a small padlock on it. But, if you right click this folder and select properties you will see a folder with a shortcut arrow under the General tab. That is why I am not exactly sure what is going on with this Music folder as it has no padlock. Open Computer and right click the Music Folder in the left pane under Libraries. Select Properties. What is shown under Library locations?



#13 JohnDohe

JohnDohe
  • Topic Starter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 22 March 2018 - 11:29 AM

@ JohnC_21

 

I booted into safe mode and went to Documents and Settings > (username) > Music.

 

I took ownership of Music.

 

Inside Music is . . . nothing; blank.

 

Here's what the properties show:

 

Attached File  Music folder in Documents and Setting - username.PNG   15.31KB   0 downloads

 

Is there anything there that says to you this folder has the shortcut arrow

you're talking about?

 

Computer, right click Music Folder in the left pane under Libraries, select Properties shows:

 

Attached File  Music folder in Libraries.PNG   35.07KB   0 downloads

 

What do you think?



#14 JohnC_21

JohnC_21

  • Members
  • 24,311 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:53 PM

Posted 22 March 2018 - 11:40 AM

Music being inside of Documents and Settings indicates to me it's a pointer but I don't see a shortcut on that music file. 

 

Is there a Read Only attribute when right clicking Music in your DOC folder? If yes, then uncheck the read only attribute and run icacls again on Music in DOC.

 

If there isn't a read only attribute then I'm out of ideas unless you want to delete the folder using Linux and see what happens. If you decide to do that I would first create a complete disk image to a USB external drive using something like Easeus Todo Backup Free after creating the bootable CD or USB flash drive from Easeus. This should be done anyway after a clean install and updates.

 

https://www.easeus.com/backup-software/tb-free.html

 

https://www.easeus.com/todo-backup-guide/winpe-bootable-disk.html



#15 JohnDohe

JohnDohe
  • Topic Starter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Local time:04:53 PM

Posted 22 March 2018 - 11:44 AM

Yes, there was that read-only attribute, which I unchecked.

 

I will do the backup!

 

Now that the read-only is unchecked, what do you suggest?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users