Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

autochk* program not found - skipping AUTOCHECK


  • Please log in to reply
17 replies to this topic

#1 markgt

markgt

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:58 AM

Posted 15 March 2018 - 05:04 PM

Hi, after removing a miner virus and various other unwanted programs that came bundled in an email using malwarebytes i now get the topic message on boot up before my laptop boots normally.After reading a post from someone on your site helping someone with the same problem i followed some advice and done a Reg Query for boot execute and got this reply                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

    BootExecute    REG_MULTI_SZ    autocheck autochk *\0autocheck aswBoot.exe /M:e44831d /wow /dir:"C:\Program Files\AVAST Software\Avast"                                                                                                                                                                                                                                                                                                                             Avast was one of the programs that came in the virus bundle which malwarebytes removed and i do not no how to fix this.Would really appreciate any help to fix this problem please.Thanks in advance. Mark

Edited by hamluis, 15 March 2018 - 05:07 PM.
Moved from Win 7 to Am I Infected - Hamluis.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:58 PM

Posted 15 March 2018 - 05:37 PM

If you cannot uninstall Avast in Control Panel use the avast uninstaller program.

 

Do this in Safe Mode.

 

https://www.bleepingcomputer.com/download/avast-software-uninstall-utility/



#3 markgt

markgt
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:58 AM

Posted 15 March 2018 - 06:02 PM

Hi, i uninstalled Avast straight away and Malwarebytes removed over 500 other suspect files,but my problem is on every boot i get a black screen after the windows logo saying 

autochk* program not found - skipping AUTOCHECK because something has been messed up in the path or registry.thanks

#4 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:58 PM

Posted 15 March 2018 - 06:39 PM

Did you use the uninstaller I linked to. This will remove remnants that the regular uninstaller of avast misses,

 

Can you access Safe Mode by tapping F8 at boot?



#5 markgt

markgt
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:58 AM

Posted 15 March 2018 - 07:01 PM

hi,yes i did use the uninstaller in safe mode, i am sorry i got the message on boot wrong, the message says ASW Boot Exe Not Found Skipping Auto check, sorry about that.



#6 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:58 PM

Posted 15 March 2018 - 08:01 PM

Can you access Normal Mode after the error? If you can then download AutoRuns. Run the program as admin and do a search for avast. Uncheck the box next to any item found. 

 

Reboot and see if you get the error. 

 

https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns

 

https://www.howtogeek.com/school/sysinternals-pro/lesson6/



#7 markgt

markgt
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:58 AM

Posted 15 March 2018 - 08:34 PM

 I found      autocheck aswBoot.exe /M:e44831d /wow /dir:"C:\Program Files\AVAST Software\Avast" File not found: aswBoot.exe can i uncheck that safely ?



#8 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:58 PM

Posted 15 March 2018 - 09:21 PM

Yes, that is safe to uncheck. If that solves the problem and the computer operates normally you can go back into AutoRuns, highlight the line and press the Red X to remove the item.



#9 markgt

markgt
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:58 AM

Posted 15 March 2018 - 09:57 PM

Thank you very much for your time and knowledge, all fixed, Cheers



#10 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:58 PM

Posted 15 March 2018 - 10:28 PM

Your Welcome, Glad you got it sorted and thanks for the update.

#11 joseibarra

joseibarra

  • Members
  • 1,286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:12:58 PM

Posted 16 March 2018 - 12:12 AM

Check one more thing by issuing the following registry query and report the exact results (or copy/paste into Command Prompt opened as Administrator):

 

Don't forget double quotes.
 
reg  query  "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager"   /v   BootExecute

Edited by joseibarra, 16 March 2018 - 12:12 AM.

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#12 markgt

markgt
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:58 AM

Posted 16 March 2018 - 12:49 AM

Hi,     HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

    BootExecute    REG_MULTI_SZ    autocheck autochk *\0autocheck ?A                                              was what i got thanks


#13 joseibarra

joseibarra

  • Members
  • 1,286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:12:58 PM

Posted 16 March 2018 - 02:13 AM

When Windows starts the autochk program checks the dirty bit on all volumes (drives) and if the dirty bit is set on any volume Windows will automatically run a chkdsk with error correction (chkdsk  /r) on the afflicted volume in an attempt to clear the dirty bit.

 

If you ever schedule a chkdsk to run on the next reboot, that will be tacked on to the end of the BootExecute value so it will run before WIndows gets too far along in the loading process.

 

So it is important that it be "right" in the registry if you want those things to work as designed or when you need them to work properly.

 

It looks like yours has some residue that I would recommend you clean up.

 

Here is what it should look like (it means to check the dirty bit on all volumes):

 

BootExecute    REG_MULTI_SZ    autocheck autochk *

 

You can reset the BootExecute to the default by issuing the following command:

 

chkntfs  /d

 

To test this in the registry I made mine look like yours (incorrect) and ran the chkntfs  /d and then it looked good:

 

BootExecute    REG_MULTI_SZ    autocheck autochk *

 

I suggest you do the same and see if that straightens things out.


The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#14 markgt

markgt
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:58 AM

Posted 16 March 2018 - 02:21 AM

after running it i got     HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

                                         BootExecute    REG_MULTI_SZ    autocheck ?A\0autocheck autochk *


#15 joseibarra

joseibarra

  • Members
  • 1,286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:12:58 PM

Posted 16 March 2018 - 03:18 AM

We'll fix it another way.

 

First make a manual System Restore Point so you can undo things later it necessary.

 

Then issue this command being mindful of the double quotes and the last asterisk (or copy/paste into Command Prompt window):

 

reg  add   "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager"   /v   BootExecute   /d  "autocheck autochk *"

 

Respond in the affirmative when asked to overwrite the value.

 

Run the query command again again to check the value which should be:

 

BootExecute    REG_MULTI_SZ    autocheck autochk *


c:\Windows\System32>


The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users