Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Defender makes Win Explorer sorting slow


  • Please log in to reply
2 replies to this topic

#1 sindyr

sindyr

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 15 March 2018 - 04:13 PM

So this is a first for me. Bear with me:

 

When I go to my Downloads folder, I can sort by Name, backwards or forwards, instantly. Same for Date Modified. But when I try to sort by the Date column, first a green bar begin to fill at the top, and then 24 seconds later, it completes the sort. Once I complete the first sort, I can resort by any column instantly.

 

Now if I disable Real-time Protection in the Windows Defender Security Center, everything is instant right off, no more problem with sorting by the Date column.

 

So for some reason Real-time Protection under Windows Defender is making it take a long time to sort folders by Date. (But Date Modified, a different column, never has trouble.)

 

I would like to be able to BOTH have RTP turned on under WinDefender but yet STILL be able to instantly sort by Date.

 

How do I do that?

 

 



BC AdBot (Login to Remove)

 


#2 mightywiz

mightywiz

  • Members
  • 755 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:05 PM

Posted 16 March 2018 - 05:58 PM

i believe when you scan a directory windows builds an index and when you make a change it has to re-index the folder and probably calls for a scan of the changed folder.  so I think your not going to find a workaround for this.

 

unless you turn off index feature maybe that will help


Edited by mightywiz, 16 March 2018 - 06:02 PM.


#3 sindyr

sindyr
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 16 March 2018 - 06:07 PM

I turned off indexing, and it did not help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users