Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Microsoft Store Apps will not close


  • Please log in to reply
12 replies to this topic

#1 bug1971

bug1971

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pa, USA
  • Local time:01:17 PM

Posted 14 March 2018 - 11:05 AM

Hello, My fellow computer geeks, I have noticed for the last month or so that all my Microsoft store apps continuously run in the task manager, Photos, calendar, calculator, Microsoft store, mail and any other store app that I downloaded. I turned off background apps but they still run. When I manually stop then they start back up again. Now normally, I wouldn't mind but the photo app sometimes uses up to 450mb of memory. Is anyone else experiencing this and if so is there any way to solve it without doing a complete reset.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:17 PM

Posted 14 March 2018 - 11:20 AM

If a laptop have you tried Battery Saver Mode. This will automatically turn off background apps.

 

https://www.howtogeek.com/241752/how-to-stop-windows-10-apps-from-running-in-the-background/



#3 bug1971

bug1971
  • Topic Starter

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pa, USA
  • Local time:01:17 PM

Posted 14 March 2018 - 04:12 PM

It's a desktop. I already tried what Microsoft told me to do and I researched it on google but still no luck. if it helps here are my system specs. http://speccy.piriform.com/results/Ip4H2Au3OjZ7PJVpWGB2Guq


Edited by bug1971, 14 March 2018 - 04:18 PM.


#4 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:17 PM

Posted 14 March 2018 - 04:28 PM

See the below link on editing the registry to stop background apps. If you are not comfortable editing the registry then don't do it.

 

You will be creating a new sub-key GlobalUserDisabled and giving it a value of 1. 

 

https://www.top-password.com/blog/prevent-windows-10-apps-from-running-in-the-background/



#5 opera

opera

  • Members
  • 970 posts
  • ONLINE
  •  
  • Gender:Not Telling
  • Local time:06:17 PM

Posted 15 March 2018 - 01:25 AM

Just asking... in taskmanager under startup tab are they listed there as running at startup?



#6 bug1971

bug1971
  • Topic Starter

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pa, USA
  • Local time:01:17 PM

Posted 15 March 2018 - 04:25 AM

No,They are running as processes in task manager


Edited by bug1971, 15 March 2018 - 05:32 AM.


#7 dmccoyks

dmccoyks

  • Members
  • 261 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:17 PM

Posted 17 March 2018 - 12:19 PM

It might be worth uninstalling your apps and reinstalling to see if it helps

https://www.howtogeek.com/224798/how-to-uninstall-windows-10s-built-in-apps-and-how-to-reinstall-them/

I would also run the following commands:

Click on Start menu
Type in cmd
Right click on cmd in list and select run as administrator
Copy and Paste the commands into the command window
sfc /scannow (best to run 2-3 times)
(Windows 8 or higher)
dism /online /cleanup-image /restorehealth
(Windows 7 or lower)
dism /Online /Cleanup-Image /RestoreHealth /Source:C:\Windows /LimitAccess
(Change C:\Windows to correct path of source)

#8 jenae

jenae

  • Members
  • 403 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 17 March 2018 - 07:24 PM

Hi, might pay to check that registry entry, surprised the link tells you to add it. I believe it is a default entry, certainly when you check (under privacy) to allow background apps that key is altered(value data is 1 for off and 0 for on).

 

Open regedit navigate to:- 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\BackgroundAccessApplications

 

Key is GlobalUserDisabled value data 1 for off, 0 for on.



#9 bug1971

bug1971
  • Topic Starter

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pa, USA
  • Local time:01:17 PM

Posted 18 March 2018 - 04:42 AM

Hey Jenae, it's at 1. IDK! nothing is working



#10 bug1971

bug1971
  • Topic Starter

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pa, USA
  • Local time:01:17 PM

Posted 18 March 2018 - 09:03 AM

I found that if I disable superfetch service it fixes my problem.



#11 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:17 PM

Posted 18 March 2018 - 09:22 AM

I can't say this will work but try the following.

 

Disable Fast Startup.

 

Toggle the switches for the background apps to on then off. 

 

Open an elevated command prompt and type the following. Windows key + X, command prompt as admin. It may say powershell

powercfg -h off
shutdown /s /f /t 0

Reboot 



#12 bug1971

bug1971
  • Topic Starter

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pa, USA
  • Local time:01:17 PM

Posted 18 March 2018 - 09:33 AM

thanks bud



#13 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:17 PM

Posted 18 March 2018 - 09:35 AM

Glad you got it sorted. I swear I didn't see your post on the fix. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users