Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


No video output on M2N-SLI Deluxe -> Troubleshooting -> Now Works..Why?

  • Please log in to reply
2 replies to this topic

#1 Parzival


  • Members
  • 1 posts
  • Local time:05:38 AM

Posted 14 March 2018 - 01:22 AM

Video output stopped working (80% of the time intermittently) and I couldn't tell why due to no on board sound ( no boot beeps ).

M2N-SLI Deluxe has no on sboard video.

Noticed the CMOS battery was weak, replaced it.

I tried all the components with known good working components and everything seemed to work fine.

Put PC back together in case with one stick of RAM ( instead of 4 ) and it seems to work fine. Have rebooted 10x with no issues ( 1 ram stick).


I'm not sure what to do now.  Do I test each ram stick?  How?  What was the problem/why is it now working?


Thank you.







Original Hardware in case used(purchased from Newegg):

Edited by Parzival, 14 March 2018 - 02:17 AM.

BC AdBot (Login to Remove)



#2 Havachat


  • Members
  • 1,006 posts
  • Gender:Male
  • Location:Sleepy Hollow - Geelong - Go Cats.
  • Local time:08:38 PM

Posted 14 March 2018 - 01:43 AM

I have a similar board M2N32 SLI Deluxe  on a destop never had an issue with anything.

Mine does Post Beeps.


You can try each Ram Module or throw em all in and see what happens.


Bit hard to say why it works now and to give an answer , its more when things dont work that suggestions can be made.


We normally dont reply if you have a Post running elsewhere.

#3 mightywiz


  • Members
  • 542 posts
  • Gender:Male
  • Local time:02:38 AM

Posted 16 March 2018 - 03:59 PM

you pulled the battery and your defaul setting probably changed, in your bios settings you should have options for either load default settings or load optimal settings, i would do the optimal settings first then put all your ram back in and try booting.  if that doesn't work then load default setting and try again.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users