Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

high CPU usage and laggy web browser


  • Please log in to reply
6 replies to this topic

#1 DallasCZ

DallasCZ

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:08 PM

Posted 11 March 2018 - 04:04 PM

Hello,

i am using a windows 10 pro system partition on SSD. Machine Lenovo Thinkpad T540p (8GB RAM).

the problem started about half year ago. It is about high windows explorer.exe CPU USAGE.

BUT the strange thing is, that it only happens on some web sites not on all, but on all browsers (chrome - my primary, iexplorer, firefox).

It happens so, that osme pages are opened normally, but others rises the explorer.exe app to 25% of CPU usage, and the page loads about 25 s (yes 25 seconds untill all banners and pictures are shownand the load page corcel icon stops turning).

I tried to boot in safe mode, but the problem is still there.

I tracked the problem down to a ntdll.dll!Rt!UserThreadStart, with stack

" ntdll.dll!NtWaitForMultipleObjects+0x14

KERNELBASE.dll!WaitForMultipleObjectsEx+0x106
KERNELBASE.dll!WaitForMultipleObjects+0xe"
I completely turned off indexing of my harddrive, because i am a Android geek so have many bilions of files on some partitions of my HDD.
Tried numerous guides how to solve this problem (i mean explorer.exe high CPU consumption by deleting all icons on the desk, changing timebullet at start to 4 (from 3)...) but nothing helped.
IT only helps to restart the explorer.exe process after i boot the computer, but then (not 100% sure if it is related) after some hours/days of use, i go to BSOD and reboot. Anytime with other error.
But afte the restart of explorer.exe process all three (abov ementioned) web browsers work fluently without HiCUPS of the CPU.
Is there a way to know which program/driver/process/ is causing that or using the ntdll.dll library so, that it eats 25 of the CPU?
Thank you very much
 


BC AdBot (Login to Remove)

 


#2 Mason21

Mason21

  • Members
  • 419 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:06:08 AM

Posted 11 March 2018 - 04:13 PM

Download Process Explorer and install. Check "verify image signatures" and "check with virus total.com"  and "verify file signatures" Anything in red under the new column "virus total" could be a virus or malware.


Edited by Mason21, 11 March 2018 - 04:17 PM.


#3 DallasCZ

DallasCZ
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:08 PM

Posted 11 March 2018 - 04:16 PM

allready done

https://drive.google.com/file/d/18qHEf31oCphAlLYrGAWKHe3IkuWZYT9-/view?usp=sharing

 

And after I checked the virus total there ar eno red rows or processes. I also used malwarebytes scan, windows defender scan and hijackthis scan to look after a malware/virus but it look tha tthe computer is clean.

I suspect some driver problem, but cannot trace the problem to the origin, because i stuck on ntdll.dll


Edited by DallasCZ, 11 March 2018 - 04:27 PM.


#4 Mason21

Mason21

  • Members
  • 419 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:06:08 AM

Posted 11 March 2018 - 04:38 PM

Did you by chance, select "no paging file"? 



#5 DallasCZ

DallasCZ
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:08 PM

Posted 11 March 2018 - 04:42 PM

where do i find that option? I should look, because i am facing the problem about 6months now and don't remember what options i turned on/off months ago.

#6 Mason21

Mason21

  • Members
  • 419 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:06:08 AM

Posted 11 March 2018 - 05:45 PM

click on File Explorer. Right click on "this PC" select "properties"  left click on "advanced system settings"  left click on "advanced" left click the settings button under Performance..left click "advanced"  Left click the "change" button under "virtual memory"  ..."automatically manage paging file for all drives" should be checked. You don't have enough memory to have "no paging file"  You need at least 16 gb for that.


Edited by Mason21, 11 March 2018 - 05:46 PM.


#7 DallasCZ

DallasCZ
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:08 PM

Posted 12 March 2018 - 12:17 AM

the paging file option is enabled.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users