Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


External HDD -- File Access Denied

  • Please log in to reply
2 replies to this topic

#1 giantslor


  • Members
  • 2 posts
  • Local time:11:24 AM

Posted 06 March 2018 - 03:39 PM

I have an external hard drive full of files that I attached to a new computer, and I followed some forum instructions to change the permissions (or maybe it was ownership) to "Everyone." It didn't work, because I can't copy/move the files to a new hard drive or run/play the files. I get a message saying that file access is denied, and I need permission from Everyone. I thought I already had done this! What course of action should I take next? Thanks.

BC AdBot (Login to Remove)


#2 JohnC_21


  • Members
  • 24,445 posts
  • Gender:Male
  • Local time:01:24 PM

Posted 06 March 2018 - 04:34 PM

Follow the below video. It's for Vista but the same steps are used for Windows 7 and I assume Windows 10.



If the video does not help then...


Do the following steps as shown in this blog. Substitute your external drive letter for E: in the below steps. On a large drive with a lot of files it will take awhile for the commands to complete. Do not interrupt the process. Each command completes when you see the prompt again.


The last version of Windows 10 uses Powershell. To get a command prompt do the following steps. After completion press the Windows key + X , command prompt as admin.


  1. Open a Command Prompt with Run As Administrator.
  2. Run this command: takeown /f e:\ /r
  3. Right-Click on the root of the copied drive - the external drive
  4. Select Properties.
  5. Click the Security tab.
  6. Click the Edit button.
  7. Select Authenticated Users.
  8. Click the checkbox under Allow for Full Control.
  9. Run this command: icacls e:\*.* /reset /t

Edit: It's hard to see the spaces in the above commands.

takeown /f e:\ /r
icacls e:\*.* /reset /t

Edited by JohnC_21, 06 March 2018 - 04:35 PM.

#3 giantslor

  • Topic Starter

  • Members
  • 2 posts
  • Local time:11:24 AM

Posted 07 March 2018 - 03:06 PM

I was set to follow the video's instructions, but then he mentioned that app that does it all for you -- so I used that, and it worked like a charm. Thanks for your help!

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users