Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

PC wakes from sleep by itself


  • Please log in to reply
13 replies to this topic

#1 OddBall8

OddBall8

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 01 March 2018 - 05:38 PM

My new HP desktop wakes from sleep without any input from me. I have disabled wake timers, the mouse, the LAN, etc. Only the keyboard is left. When the computer wakes by itself, I enter powercfg -lastwake in Command prompt. It doesn't show the source. In event viewer, the wake source is shown as unknown. How do I stop my PC from waking by itself?

 

 

Attached Files


Edited by OddBall8, 01 March 2018 - 05:41 PM.


BC AdBot (Login to Remove)

 


#2 mightywiz

mightywiz

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 01 March 2018 - 06:20 PM

disable sleep & hibernate modes, both are problematic and have been since windows 95.

 

besides your computer could use a nice rest once and a while meaning a nightly shutdown and restart in the morning is not a bad thing at all.



#3 jenae

jenae

  • Members
  • 884 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 01 March 2018 - 10:34 PM

Hi, open a cmd as admin and type:-

 

powercfg -devicequery wake_from_any (press enter)

 

This lists all the hardware devices that are capable of waking up the computer from standby. But the operating system typically ignores most of them. To see the ones that are not being ignored, run the command

 

powercfg -devicequery wake_armed (press enter)

This second list is typically much shorter. On my computer, it listed just the keyboard, the mouse, and the nic .

 

You can disable each of these devices one by one until you find the one that is waking up the computer.

 

powercfg -devicedisablewake "device name"



#4 OddBall8

OddBall8
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 02 March 2018 - 06:43 AM

I do shut down my PC at night. I wakes up during the day when I sleep it. I tried powercfg -devicequery wake_armed and it returned only the keyboard. But I don't press anything on the keyboard. I will try disabling bluetooth since I don't use it.



#5 mightywiz

mightywiz

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 02 March 2018 - 01:03 PM

is it an infra-red mouse, wireless?   turn if off or pull the battery. when you put it to sleep.  see if that is causing your issue.



#6 OddBall8

OddBall8
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 02 March 2018 - 06:00 PM

I have an infrared/plugin mouse. Its wake ability has been turned off.



#7 jenae

jenae

  • Members
  • 884 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 03 March 2018 - 07:10 PM

Hi, time to see if it's win 10's new schedules (v1709, changes), press the win +x keys together select Powershell(admin) copy this cmd and right click anywhere in the powershell window, the cmd will append to the prompt, press enter.

 

 

 

Get-ScheduledTask | where {$_.settings.waketorun} |out-file $home\tasks.txt
notepad $home\tasks.txt
 
Please copy paste the notepad output here, you can safely disable all entry's if you wish, under task scheduler (search type:- task scheduler (expand to microsoft, windows)

Edited by jenae, 03 March 2018 - 07:11 PM.


#8 OddBall8

OddBall8
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 04 March 2018 - 07:08 AM

TaskPath                                                             TaskName                                                    State     
--------                                                                  --------                                                            -----     
\Microsoft\Windows\.NET Framework\             .NET Framework NGEN v4.0.30319...          Disabled  
\Microsoft\Windows\.NET Framework\             .NET Framework NGEN v4.0.30319...          Disabled  
\Microsoft\Windows\rempl\                                shell-usoscan                                               Ready     
\Microsoft\Windows\SharedPC\                        Account Cleanup                                          Disabled  
\Microsoft\Windows\UpdateOrchestrator\         Reboot                                                          Disabled  


#9 OddBall8

OddBall8
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 04 March 2018 - 07:14 AM

The first line of text didn't return anything. Under task scheduler, I'm not sure how to search.



#10 jenae

jenae

  • Members
  • 884 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 05 March 2018 - 02:41 AM

Hi, you say this is a new machine? Surprised you have the remsh.exe , part of Microsoft\Windows\rempl\ ...shell-usoscan, (wakes the computer every day to check for updates), as far as I was aware this was for earlier versions, updating. Open search and type:- winver (press enter), what version shows?  



#11 OddBall8

OddBall8
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 05 March 2018 - 08:24 AM

here

Attached Files



#12 Allan

Allan

  • BC Advisor
  • 8,646 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:10 PM

Posted 05 March 2018 - 08:33 AM

disable sleep & hibernate modes, both are problematic and have been since windows 95.

 

 

 

+1 - Neither mode necessarily works as expected in all configurations.

 

Instead of hibernation or sleep, simply set your hd & display to power down after a defined period of inactivity.


Edited by Allan, 05 March 2018 - 08:34 AM.


#13 jenae

jenae

  • Members
  • 884 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 05 March 2018 - 07:01 PM

Hi, I agree with Allan's suggestion, just MS tasks run at high priority and will still wake the computer, so it is not a fix.

 

This is from an earlier thread read ALL of it before you plow in.

 

https://www.bleepingcomputer.com/forums/t/661058/remplremshexe-wakes-up-sleeping-pc-every-day/



#14 IttechGyan

IttechGyan

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:10:40 PM

Posted 06 March 2018 - 04:52 AM

You can change the permissions of the update service so that it no longer has the ability to wake the computer.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users