Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Windows 10 Networking Issues - Error 651

  • Please log in to reply
No replies to this topic

#1 archie_finch


  • Members
  • 2 posts
  • Local time:11:56 AM

Posted 19 February 2018 - 11:39 AM

Hello all,


For the last couple of days Im facing some serious problems connecting to my home wifi through my laptop (Dell Inspiron 15 7559) running  windows 10.


The issue first started around 2 days ago when i connected to my wifi but got a yellow exclamation mark on the wifi icon. 


At first i tried rebooting both - router (Asus RT-N12D1) and my laptop, but to no avail. I should also mention that i got the same

error on my samsung s7 when i tried to connect to the wifi network (internet may not be available).


I tried to connect the cable directly to my laptop's ethernet port and tried setting up broadband (PPPoE) connection using the credentials provided by my ISP.

But i would get error 651 :(


After that I tried to do the same thing using another laptop running windows 10 as well. And voila! I was able to setup the broadband connection

and got internet access :)


Determined to find the root cause for error 651 when connected to my laptop, I did some searching on the internet.


Among several solutions suggested on different forums/blogs/articles, I went with typing the - netsh int ip reset reset.log command on powershell.

I then restarted my laptop AND I was able to setup the wired connection and got internet access! NO error 651 finally!! I reset the router and the wifi was working as well!!


But the problem returned today. I tried executing the same command from powershell and restarting my computer - but this time it didn't work :((


I then tried few different approaches as well:

(1) executing - netsh interface tcp set global autotuning=disabled command
(2) Unchecking the IPv6 option. 

After following these 2 approaches, i tried plugging in the cable in my ethernet port and for a moment the yellow exclamation mark disappeared. But

after that I again got "No internet" popping up.


I again plugged in the cable to a second laptop and it was working normally! I then connected the cable back to the router to see if I could connect to 

the wifi using the second laptop. But the connection would take forever and then drop. I tried resetting the router again and updating the firware on my router as well..

But it still didn't work.


I tried connecting my laptop to a different wifi network (w/ PPPoE connection) and it seems to be working just fine. 


It's just that when I try to plug in the cable to my router and my laptop i would get no internet connection :(


I really don't know what to do at this point. Any help would be much appreciated.. thanks!


- Archie


PS. I use chrome and have to keep lots of tab open for school research work, so heavy memory usage.  

Edited by britechguy, 19 February 2018 - 11:43 AM.
Moved to Networking

BC AdBot (Login to Remove)



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users