Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Windows won`t boot with nvidia drivers, just the generic one

  • Please log in to reply
2 replies to this topic

#1 razoras


  • Members
  • 8 posts
  • Local time:10:51 AM

Posted 15 February 2018 - 03:53 PM

Geforce 770gtx. Got a random bsod during gameplay (video memory scheduler error I think) and afterwards my pc wouldn't get to the desktop.Watching the dump file with blue screen viewer the files "dxgmm2.sys" and watchdog.sys are marked as red. It gets as far as the blue Windows window, then GPU stops, tries for a few seconds and  then reboots. I can however boot into safe mode so I know my gpu isn't totally dead, and my display is working fine too.If I uninstall the gpu driver in safe mode with DDU I can boot into normal windows, but when I install a display driver again the install fails halfway through(usb unplug sound and the gpu stops working), I get a black screen as if no signal from gpu, then after reboot the same thing happens everytime i boot the windows, before i DDU the nvidia drivers and start with the generic ones. I've had the driver installed for a few weeks before so it's not a faulty driver.Computer also doesn't seem to know what type my monitor is, I point it to the monitor driver but it says the best driver (Generic non-PnP) is already installed.SFC gives no errors, chkds no error. Windows Startup repair, as usual, does nothing. Could it be some component of my GPU that's failed, and the driver can't access it, like a video memory component or something?And why does it boot fine in safe mode and install the driver in safe mode. This makes me think it might be a software problem.. I've unplugged all unnecessary peripherals and double checked all my bios settings too..Windows version is the latest, thought it was the creators update that was causing the issues, but i tried all sorts of windows versions, issue persists during the installion of the driver and after the driver halfway installs, gpu chrashes, have to do a DDU and then start the pc with generic drivers again and repeat.
Things i tried so far are:
-Clean Windows 10 copy, Clean windows 7 copy with all sorts of driver versions, 384, 362 etc.
-Tried installing the driver with unplugged monitor because i read somewhere that there were some issues with monitors.
-Downgrading Intel management interface.
-Upgraded bios to the latest.
-Tried installing the driver through device manager manually.
Also worth a note that at one point for one day i was able to install all sorts of drivers with no problems, but the games kept crashing a few seconds into the game and error used to pop up "Access to the device was resticted" and so on, the windows did not stop responding, but the game did and after awhile the same bsod happened and i could never duplicate this period of success. This period happened when i upgraded from windows 10 fall version to the current newest, which is 1709.
-did a disk check
-did a memory check
Added the dump file.

BC AdBot (Login to Remove)



#2 XboxUnity


  • Members
  • 11 posts
  • Gender:Male
  • Local time:06:51 PM

Posted 17 February 2018 - 01:54 AM

So updating the driver doesn't help...


Maybe try this:


  1. Uninstall the driver and keep it on the generic one
  3. Let that attempt to install the GAME READY DRIVER
  4. If it works, restart and see the result

Hope this helps!



#3 razoras

  • Topic Starter

  • Members
  • 8 posts
  • Local time:10:51 AM

Posted 17 February 2018 - 05:12 AM

Thanks for the the advice, Chris, same results though :)

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users