Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 PCs get no home WiFi when joined to office domain.


  • Please log in to reply
1 reply to this topic

#1 lsquez

lsquez

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:58 PM

Posted 12 February 2018 - 03:11 PM

We have Windows 10 laptops and Surfaces that experience this issue. When the laptop is in a workgroup, they appear to not experience the issue. The issue also does not always occur right away. Once the Windows 10 PC is joined to the domain, it works fine in the office. When they take it out of the office, it won’t connect to WiFi.

 

We have run the following commands as suggested in the forums, but they have not solved the issue.

 

netsh winsock reset catalog

netsh int ipv4 reset reset.log

netsh int tcp set heuristics disabled

netsh int tcp set global autotuninglevel=disabled

netsh int tcp set global rss=enabled

sc config NlaSvc start= delayed-auto

ipconfig /release

ipconfig /renew

ipconfig /flushdns

ipconfig /registerdns

 

We have tried removing the WiFi hardware from the Device Manager and rebooting.

We have tried updating the WiFi drivers.

We have tried running a ‘Windows Refresh’, and a ‘sfc /scannow’.

 

When we run the troubleshooting, we get the following message…

‘Windows does not have a valid IP configuration and it was not fixed’

 

There are no WiFi policies on the domain. There are no encryption settings in Group Policy.

 

From our testing the PCs do not obtain an IP address and the networking shows ‘No Internet, Secured’.

 

We have worked with both Sonicwall and Microsoft and they have been able to confirm that the DORA request is not being handled correctly by the Windows 10 PCs.

 

The only solution we have so far is a complete reload of the PCs, but this is not a workable solution.


Edited by britechguy, 12 February 2018 - 03:29 PM.
Moved to Networking, as this is a networking problem that happens to be occurring under Windows 10


BC AdBot (Login to Remove)

 


#2 King_Yoshi

King_Yoshi

  • Malware Study Hall Senior
  • 1,361 posts
  • OFFLINE
  •  
  • Local time:04:58 PM

Posted 12 February 2018 - 04:38 PM

:step1: If its a problem with the DORA request, then there is a problem with the network stack on those computers.
Since I saw you already sent the commands to reset the network stack "netsh winsock reset catalog" and the problem is still occurring, there may be corruption in the underlying files.

I would suggest taking one of the laptops and doing a reinstall without overwriting files with one of the computers.
If this fixes the problem then you know the problem was related to corruption in the system files and you will have to do this for every laptop.

 

If you can get into Windows, press the shift key whilst clicking Restart to get to the Windows Recovery Environment

 

If you cannot get into Windows, start your PC, then just as Windows attempts to load, press and hold Power Button for 5 - 10 seconds to perform a hard shut down

 

Do this twice

 

On the third start Windows will boot into the Recovery Environment and from there you can access System Repair, Safe Mode, Command Prompt . . . etc.

 

Go to Troubleshoot - Advanced Options - Reset this PC

 

You will then have 3 options:

  1. Keep my files and Apps
  2. Keep my files
  3. Keep nothing

Select the option that suits your needs and click Reset

 

For best results make sure your device is not connected to the Web and unplug all USB devices . . .

Source:
https://answers.microsoft.com/en-us/windows/forum/windows_10-update-winpc/reinstall-windows-10-without-cd-and-without-losing/f4818ef7-4828-43f8-bd71-a5854ec56756?auth=1

 

:step2: The other thing I am wondering is if the user is taking the laptops home with them and are not connecting locally within your domain, it could be that the computers are keeping the IP Addresses assigned to them from your domain, instead of getting new IP Addresses from their home routers. If this is the case, the error your receiving makes sense. Have you tried assigning a static IP Address for a user that is within their home routers IP range? 

I saw you ran IPconfig /release, and /renew, which should fix such a situation, but if there is a problem with DORA requests, this may be a temporary workaround.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users