Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

XP Pro laptop sees only 2 of 3 W10 PCs


  • Please log in to reply
9 replies to this topic

#1 oldcelt

oldcelt

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Herefordshire UK
  • Local time:01:17 PM

Posted 12 February 2018 - 10:33 AM

There are 4 machines on my LAN.   The one laptop running XP Pro (no, it won't run anything better!) sees two of the LAN machines but not the third one.

 

Any ideas please?


Edited by britechguy, 13 February 2018 - 10:11 AM.
Moved to Networking. Something weird in networking is going on that's not likely specific to any one Windows version.


BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,643 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:09:17 AM

Posted 12 February 2018 - 10:56 AM

Yes.

 

On the machine that remains invisible:  Control Panel->Network & Sharing Center->Advanced Sharing Settings Link

 

In the dialog, make sure that you are connected using a Private profile and that the Turn On Network Discovery radio button is selected as well as the checkbox that goes with it.

 

If the machine in question thinks it's connected to a public network all bets are off as far as others seeing it.  If you do see that the profile in use is "Public" then try this first:  Settings->Network & Internet->WiFi Pane (presuming you're connected via WiFi)   Click on the name of the WiFi network to which you're connected and then in the dialog that pops up make sure it's considered private, not public.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 


#3 oldcelt

oldcelt
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Herefordshire UK
  • Local time:01:17 PM

Posted 12 February 2018 - 01:07 PM

Many thanks.   I've closed the office for today but will try your suggestions in the morning.



#4 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,643 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:09:17 AM

Posted 12 February 2018 - 01:10 PM

Let us know how it all turns out.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 


#5 oldcelt

oldcelt
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Herefordshire UK
  • Local time:01:17 PM

Posted 12 February 2018 - 01:15 PM

Sure, will do.



#6 oldcelt

oldcelt
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Herefordshire UK
  • Local time:01:17 PM

Posted 13 February 2018 - 09:55 AM

OK, this is the situation.  

There are 4 PCs on the LAN.   All are set up on the same Workgroup and all are using ‘Private Profile’.   Using Windows Explorer the Network machines shown are as follows:-

  1. Dell Laptop (Windows XP Pro) – lists itself, (2) and (3) but not (4)
  2. Acer Aspire (Windows 10 Pro) – lists All 4
  3. Samsung Netbook (Windows 10 Pro) – lists itself, (1) and (2) but not (4)
  4. PC Specialist Desktop (Windows 10 Pro) – lists itself and (3) but not the other 2

'Turn on Network Discovery' is selected on all.

 

Weird!

Ken


Edited by oldcelt, 13 February 2018 - 09:56 AM.


#7 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:06:17 AM

Posted 20 February 2018 - 12:33 AM

Is your LAN a single router or switch or is it more complex? Specifically, is there a WiFi link between any two devices that are not PC's ? (looking for a potential problem with a wireless bridge) Can you try to ping the IP address of each computer from each of the others? (looking for a Windows network problem that doesn't impact TCP/IP) Can all computers get to the Internet independently?



#8 oldcelt

oldcelt
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Herefordshire UK
  • Local time:01:17 PM

Posted 20 February 2018 - 12:00 PM

My network is controlled by a TP-Link router.  That has wi-fi connections with 2 x W10 machines.  There is a Netgear mains extender to my office where I have a modified Netgear router providing an access point.  (wireless and ethernet options)

 

All computers get to the internet via the router independently.   (I assume you meant without going via another PC on the LAN?)

 

Every PC can ping every other PC successfully.

 

The listing of PCs on the LAN seems to vary daily! :-(   Not as consistent as I thought when I penned my message on 13th Feb.   For example, PC Specialist Desktop (Windows 10 Pro) – now lists Samsung and the Acer Aspire only.  (Using Windows Explorer).



#9 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:06:17 AM

Posted 21 February 2018 - 02:41 PM

OK, let me guess you have two devices sharing the Netgear over the mains adapter. My bet would be that if you check the ARP table on one of the TP-Link connected PC's (cmd screen, enter "arp -a") you will find multiple IP's with the same MAC address, and those will be the PCs and other devices connected to the Netgear. Checking the OUI (first six digits of the MAC that identify the manufacturer) will probably tell you whether it's the Mains adapter or Netgear that's eating your lunch (my bet is the Mains adapter). You'll probably find the same thing going the other way. The problem is that many mains adapters and some wireless bridges transport only a single MAC address across the link - their own. This allows any one device on the far end to communicate just fine, but since all traffic on the local LAN is addressed by MAC, not IP address, exactly which device is communicating at any specific time becomes undefined. Generally it's whoever spoke last. Which can get really confusing to most protocols. The solution here would be to set your Netgear back to being a router and using it's WAN port over the mains adapter - which means your now routed devices will use the Router's MAC to get across the link, and the router can figure out what goes where locally. This is unfortunate because it splits your LAN in half, with different IP addresses on both sides. You probably want to turn off NAT on the Netgear too, especially if you have need to access things on that net from the other, like file shares or printers. It's adding a lot of complexity, but it should solve your problem.



#10 oldcelt

oldcelt
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Herefordshire UK
  • Local time:01:17 PM

Posted 21 February 2018 - 02:57 PM

Thank you for that extensive analysis and suggestions for a solution.  You'll see that it's now approaching my bedtime ( :dance: ) so I'll have a good look in the morning.

 

Thanks again, Ken






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users