Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Hp Pavilion 23 Boot order setting showing UEFI as first?


  • Please log in to reply
5 replies to this topic

#1 mystic12

mystic12

  • Members
  • 1,556 posts
  • OFFLINE
  •  
  • Local time:05:58 AM

Posted 06 February 2018 - 12:11 PM

Hey guys, I would like to confirm something with this situation please. Owner brought a dell laptop and this Hp Pavilion 23 pc with the same symptoms, on powering it's not recognizing a boot device. I had to reload win10 on the laptop and replace the HDD on this desktop and all was well but now both computers started showing the same symptoms again. I could only suspect maybe some virus activity on her network causing the same problems with multiple pc's but she called verizon who told her there is no such thing as a virus being on their line, which I understand. What I am not understanding is why they could not send someone to check the network for viruses, not the line?

 

Also, I had disabled secureboot and enabled legacy to reload OS on both units but now checking the desktop the boot options was showing as UEFI so reset it back to legacy and now restarting 13 times, no issues.

 

I notice every time I press f9 to see the boot menu the white arrow to the left of the list is always showing on UEFI as in the pic. In the bios same deal as in 2nd pic, I am wondering if something might be wrong with the bios which may have caused the boot options to go back to UEFI or is this normal please? 

 

https://s10.postimg.org/d8xhc1ka1/20180206_110509.jpg

 

https://s10.postimg.org/r2lu14fg9/20180206_110714.jpg

 

 



BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,602 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:05:58 AM

Posted 06 February 2018 - 01:54 PM

From what I can see this is normal.

 

If you've turned off secure boot then UEFI will only look for external USB devices to boot from and if none are present you jump straight into the legacy boot order.  You can't "get rid of UEFI" it's part of the machine's firmware.  I also would not do what you're doing if this is newer equipment which was designed for secureboot and UEFI from the outset.  It makes things less secure and should have absolutely nothing to do with the issues described.  If there's a boot device present, usually the HDD, that UEFI hits first it will boot from it just the same way that using legacy methods does, but with a bit tighter control around it.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 


#3 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,556 posts
  • OFFLINE
  •  
  • Local time:05:58 AM

Posted 06 February 2018 - 01:56 PM

So I should set all options back to UEFI and enable secureboot?


Edited by mystic12, 06 February 2018 - 01:56 PM.


#4 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,602 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:05:58 AM

Posted 06 February 2018 - 01:59 PM

That's what I would do.   It's entirely your choice, though.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 


#5 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,556 posts
  • OFFLINE
  •  
  • Local time:05:58 AM

Posted 06 February 2018 - 02:03 PM

Far as I can remember every time I have reloaded OS on a win8 or 10 machine, I have had to first disable secureboot then enable legacy. Is that the normal entire procedure but also when done then go back to enabling secure boot then choose UEFI?



#6 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,602 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:05:58 AM

Posted 06 February 2018 - 02:12 PM

You should not have to do anything to reinstall Win8 and onward as far as tweaking UEFI other than boot order, of course, since you need to boot from either the optical drive or a USB thumb drive.

 

I've never turned off secureboot and gone to legacy on machines that originally came with UEFI and Windows 8 or later.  If it's an older, pre-UEFI machine then this becomes irrelevant under true BIOS.  I guess it could be required, but I don't know one way or another, on the rare machine that was UEFI with Windows 7 for the brief period just before Windows 8 came along, but I would presume secureboot would already be off on those boxes.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users