Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Most rear USB3 ports stopped working


  • Please log in to reply
2 replies to this topic

#1 BewareOfButtlice

BewareOfButtlice

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:16 AM

Posted 04 February 2018 - 03:40 PM

So I have been recently having this issue where when i plug in my Saitek x52 joystick, my mouse, keyboard, and head tracker (TrackIR v5) stop working. In the Device manager, they show up as an Unknown USB Device (Device Descriptor Request Failed) and the properties for each device show error code 43.

 

After a quick restart, my devices started working again. However, they would shortly stop working with the same error code listed above. When i have the joystick disconnected, the mouse, keyboard, and head tracker work great. So to attempt to resolve the issue, I connected to my computer with TeamViewer and uninstalled all USB Hub and USB 3.0 Host Controllers to then install the drivers from windows update once the computer restarts. Now the USB ports that had the mouse/kb/head tracker no longer work with anything. All the USB hub/3.0 host controllers installed without issues. I have changed the power management of each USB hub to not allow windows to shut off to save power. If i disconnect my Oculus Rift and plug in the devices to those USB ports, they work just fine and i can also plug in my joystick without having them disconnect! But now i only have 2 USB ports that work on the back... The ports have no visual damage. I have used a bootable OS and all ports work fine, which tells me its a driver/software issue. I tried a clean boot with the same issue, USB devices don't work in anything but two ports on the back. I ran SFC and it completed without finding any issues. There are no drivers available for Windows 10 for my motherboard so i am at a loss for what to do next. Any ideas?

 

Windows 10 Pro x64
Intel i7-3770K @ 3.5ghz
16gb ram
Nvidia Geforce GTX 680
Keyboard: Saitek Eclipse (the OLD one)
Mouse: Razer DeathAdder RZ01-0015
 
Not sure why it says my tiny little SSD says it has a SMART failure, there are no faults with the drive.
 
EDIT:
I tried plugging in a 3.0 flash drive and it works just fine. Just my mouse/kb/TrackIR dont work...

Edited by BewareOfButtlice, 04 February 2018 - 03:42 PM.


BC AdBot (Login to Remove)

 


#2 mjd420nova

mjd420nova

  • Members
  • 1,925 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:16 AM

Posted 04 February 2018 - 04:01 PM

Apparently a driver for the joystick is interfering with the drivers for the mouse/keyboard.  The driver isn't active untill the joystick is "sensed" and the driver loaded on top of the previous keyboard/mouse drivers.



#3 BewareOfButtlice

BewareOfButtlice
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:16 AM

Posted 04 February 2018 - 05:25 PM

Sounds about right. But even with the joystick disconnected, only two of the USB ports on the back work for mouse/kb/TrackIR. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users