Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need help with the LTSB edition of Windows 10, user accounts, and apps.


  • Please log in to reply
No replies to this topic

#1 ScarXL

ScarXL

  • Members
  • 102 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:EU, RO
  • Local time:05:41 AM

Posted 01 February 2018 - 07:10 AM

I decided to post here because I have no idea what to do anymore. I almost gave up on trying to fix this.

 

Before I start explaining, the edition of Windows 10 that I have is Windows 10 Enterprise 2016 LTSB. The reason why I'm using this edition is that I really liked the features it had, no pre-installed apps that I don't need, no telemetry, no adverts ("Get Skype/Office 365 Now!"), Local account by default etc.

 

I saw that I could still get the Store and Xbox apps to work by running a batch file somebody made:

 

http://virtualcustoms.net/showthread.php/72904-Install-Microsoft-Store-and-Apps-on-Windows-10-LTSB-2016

 

Here's what happened and what I need help with.

 

After I installed this edition of Windows 10, I made my user account an administrator and set up my profile. After a while later, I decided to move everything from this user account over to the built-in administrator account (which was a stupid idea now when I look back at it).

 

After moving everything, I saw that UWP apps could not run on the built-in administrator account, and I followed a tutorial to make them work by changing some policies.

 

Everything's fine, I installed Store and Xbox on the built-in administrator account and they run perfectly well, and so did the Search and PC Settings apps.

 

I needed to login with my Microsoft account in the Microsoft Store to download a game, but it hijacked my account and somehow transformed the built-in administrator account from a Local Account to my Microsoft Account. I forgot to skip past the dialog where it asked me to convert my account.

 

Now, I went to PC Settings --> Accounts, and tried to switch back to a Local Account, but there was no "Sign in with a local account instead" button. And now my administrator account is stuck like that.

 

I decided to just make a new administrator account and forget about the built in administrator account, deleting the "Administrator" user folder and disabling it in cmd using "net user Administrator /active:no".

 

I tried installing the Xbox and Store apps again on the new account, and so the real issue appeared.

 

My Store and Xbox apps won't register in powershell.

 

In my vain attempts to fix this, looked up the error that I got "The specified file could not be found (AppxManifest.xml)" and apparently my AppRepository database file is corrupted and doesn't include the manifest .xmls for the Store and Xbox apps.

I made a backup of the 6 database files:

 

qStxT9x.png

 

And tried deleting them and letting the State Repository Service rebuild them. I tried running a Powershell register of all apps again, and it only registered the Xbox and Store apps. It didn't register my system apps. And I was left with my Settings app, start menu, and Search app, all not working.

 

I restored the original files and now my System apps work, but the Store and Xbox apps don't work.

 

So finally, here are my questions:

 

1. How can I remove my Microsoft Account from the built-in administrator account?
2. How can I completely uninstall the Store and Xbox apps, and only keep my system apps (from all user accounts)? [I want to reinstall them from scratch on this new account]

3. How can I rebuild the database to include every .xml file or add the missing manifest files myself? [In case the reinstallation doesn't work]

 

(Note: I did try to run "DISM /Online /Cleanup-Image /RestoreHealth" and "/sfc scannow", none of them helped.)

 

Thanks in advance. I really need help here, I was stuck on this issue for god knows how long.

If you need any more information, feel free to ask me.


Edited by ScarXL, 01 February 2018 - 07:16 AM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users