Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Certain games crash after opening


  • Please log in to reply
4 replies to this topic

#1 xPinkpony

xPinkpony

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:07:29 AM

Posted 31 January 2018 - 08:12 PM

I'm having an issue with three games on my computer, Hearthstone (HS), Counter Strike: Global Offensive(CSGO), and League of Legends(LOL).

When I try to open HS and CSGO they would appear in task manager for a short time then disappear as if I had never even opened them.

For LOL I can use the client for anything but if I try to load into a game the same thing happens.

It tries to load then disappears and sends me back to the client with a reconnect screen.

With all three games I have tried uninstalling and reinstalling, repairing, and Installing to my other hard drive.

The latter only works with HS for a short time then it stops working again.

Also sometimes when I startup my computer they just work and I'm not sure why.

I have also tried running Malwarebytes and CCleaner. 

I can play any other Steam games just fine as well as other Blizzard games.

This only started happening 2 weeks ago out of nowhere.

 

In event viewer I can see errors for every time I've opened the games but I'm not sure what info from there is useful.

 

I'm running Windows 7

CPU: i7-4790k 4GHz

GPU: GTX 680

RAM: 16 GB

HD1: ST 500GB

HD2: WD 3TB

2 monitor setup


Edited by xPinkpony, 31 January 2018 - 08:13 PM.


BC AdBot (Login to Remove)

 


#2 C0bra

C0bra

  • Members
  • 171 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:12:29 PM

Posted 01 February 2018 - 08:45 AM

Has anything changed as of late? Did you get a new anti-virus? Install a new program? Have you tried running them as Administrator?

 

There are a number of reasons the games could cut out like that right away. First try turning off your anti-virus, and if not, disable the firewall too, it's possible that they're being blocked. Some silly programs like FPS counters and performance boosters can affect games like that too. (Fraps, Razer Game Booster; to name a couple.)

 

Give those a quick try and let me know if it works. Let's start knocking things off the list.


 | IT Service Tech | A+ Certified | Computer Gamer | iPhone Expert |

nIDwkQT.gif


#3 xPinkpony

xPinkpony
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:07:29 AM

Posted 01 February 2018 - 06:16 PM

After disabling Avast shields everything seems to work, but they're even working after I re enabled the Avast shields. Not sure if that's supposed to happpen.



#4 C0bra

C0bra

  • Members
  • 171 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:12:29 PM

Posted 01 February 2018 - 06:26 PM

After disabling Avast shields everything seems to work, but they're even working after I re enabled the Avast shields. Not sure if that's supposed to happpen.

 

Nailed it!

 

It's possible Avast built exceptions once it enabled again. Hard to say, Anti-virus can do some pretty funky things. Glad everything is working!


Edited by C0bra, 01 February 2018 - 06:26 PM.

 | IT Service Tech | A+ Certified | Computer Gamer | iPhone Expert |

nIDwkQT.gif


#5 xPinkpony

xPinkpony
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:07:29 AM

Posted 02 February 2018 - 04:10 PM

Alright! Day 2 and everything is still working perfectly fine. Thank you so much!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users