Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop wifi constantly disconnecting and very slow on school wifi.


  • Please log in to reply
1 reply to this topic

#1 Tonyh98

Tonyh98

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 31 January 2018 - 12:03 PM

Honestly this problem started about a week ago and I have no idea what caused it nor how to fix it. I have a toshiba c55 satellite laptop using Broadcom 802.11n version 7.35+. When I'm at school the wifi constantly disconnects and is quite slow whereas my phone works perfectly fine (30-50mbps) whereas my laptop gets 1-5mbps. I thought I was probably a virus so I completely reformatted my laptop but am still experiencing this issue. People around me are using the schools wifi completely fine, guy next to me was watching Netflix when I can't even load a website. I tried everything, virus scans, reformatting, uninstalling network adapter, using the command DNS flush, using the net sh ip command, my IPv4 & 6 are set to automatically configure up, turning the allow pc to shut down wifi to save battery off. Nothing works what is going on? I might buy a wifi dongle but I want to fix this

Troubleshooter sometimes says no issues found, other times says problem with wifi adapter/access point and sometimes says DNS not configured properly. But at home my wifi works fine just at school it seems.

Edited by Tonyh98, 31 January 2018 - 12:16 PM.


BC AdBot (Login to Remove)

 


#2 mightywiz

mightywiz

  • Members
  • 755 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:16 PM

Posted 31 January 2018 - 03:58 PM

so go into the device manager and then double click on your wifi adapter.

 

in the popup window select the advanced tab and look for 802.11n bandwidth, select it and in the window to the right it should say "20Mhz only" or "20/40Mhz Auto"  make sure it's on the 20/40 auto.

 

if this is your issue then great!  if not then i would try tcp optimizer from speedguide.net

in it you select your wifi adapter and and then hit the optimize option at the bottom then hit "apply changes" and it will tweak some other setting like MTU and others that can help increase speed.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users