Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Why won't my scheduled task work?


  • Please log in to reply
No replies to this topic

#1 gib65

gib65

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:08:04 PM

Posted 29 January 2018 - 10:59 AM

Hello,
 
I'm trying to schedule a task in the Task Scheduler on Windows Server 2016. The task is to reset a website in IIS. It's supposed to run every 5 minutes.
 
Here is the action:
 
"appcmd.exe" start site /site.name:Default Web Site
 
This keeps giving me a 0x57 error.
 
I know that this works because I've verified it:
 
"appcmd.exe" start site /site.name:testsite
 
Therefore, it seems to me that the problem is with Default Web Site. I'm guessing appcmd doesn't know how to handle the spaces in the name. I tried this but this doesn't work either:
 
"appcmd.exe" start site /site.name:"Default Web Site"
 
Does anyone know how I would set the website to be restarted as the Default Web Site? Thanks.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users