Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Formatted 64gb USB to Fat32. Now not recognised on Windows 10, but fine on XP


  • Please log in to reply
17 replies to this topic

#1 ChrisHateley1982

ChrisHateley1982

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 27 January 2018 - 09:01 AM

Okay, this may be a little complicated...

 

I recently bought a Kingston 64gb USB stick to store video files on. For whatever reason half my files would no longer play on my TV when I transferred them from a 16gb (even though they played fine on the old USB). 

I read online that formatting to Fat32 might help so I downloaded a program to do that (EaseUS) on my Windows 10 laptop and formatted successfully. Just to be sure, I ejected the USB, re-inserted. USB recognised. Fat32. Mission accomplished.

 

I then put the USB in an old PC I only use to download stuff, running Windows XP. USB still worked fine.

I returned the USB to my Windows 10 laptop, and it wasn't recognised. Got a tone to acknowledge I'd just plugged something in, but that's all. No error message, nothing. Like the USB just wasn't there. Tried it in the second USB port. Still nothing. I returned it to my Windows XP machine, it showed up fine. Just won't work on my laptop, even though that's were I formatted it in the first place and it worked fine the first time I unplugged and reinserted.

Any ideas how to remedy this?



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:24 AM

Posted 27 January 2018 - 09:31 AM

Open Disk Management in the Windows 10 computer with the drive attached. Is it detected and does it have a drive letter associated with it?



#3 ChrisHateley1982

ChrisHateley1982
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 27 January 2018 - 12:00 PM

Ok, it appears the problem may be with my laptop.

 

I checked disk management and it wasn't visible in there, so I inserted another USB to see which letter was associated with that drive and now that one isn't showing up either.



#4 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:24 AM

Posted 27 January 2018 - 12:24 PM

This is the Windows 10 computer, correct? Are there any yellow exclamation marks in Device Manager? 

 

Download DeviceCleanupCmd Not the GUI version.  Unzip the folder to your desktop. In that folder will be a folder called X64. Copy the X64 folder to the root of C:

 

Open a command prompt. On the later builds of Windows 10 this is Powershell. You will need to set this to Command. After changing form Powershell to the Command shell open an elevated command prompt. Press the Windows key + X. Command as admin. Type the following commands. Detach any USB storage devices first.

cd c:\x64
devicecleanupcmd *

Reboot

 

This will delete all non-present devices. The next time you attach a USB flash drive it will load the drivers again. Sometimes the drivers on the USB ports can conflict.

 

If the computer still does not detect USB drives we can determine if this is hardware or software related.



#5 ChrisHateley1982

ChrisHateley1982
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 27 January 2018 - 12:30 PM

Thanks but before I do all that; I just scanned for new hardware and got the device to show up in Device Management, and clicking on properties gives me this message:

 

"Windows cannot load the device driver for the hardware because a previous version of the device driver is still present in memory. (code 38)

 

The driver could not be loaded because a previous version of the driver is still in memory."

 

 

I guess that's the problem, right?


Edited by ChrisHateley1982, 27 January 2018 - 12:37 PM.


#6 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:24 AM

Posted 27 January 2018 - 12:35 PM

For some reason I'm not getting an image. You can click more reply options and upload the jpg file.

\

 

Okay, I got the image.

 

Edit: Do the following first. Disable Fast Startup. Once Fast Startup is disabled open an elevated command prompt. Windows key + X  as admin. Powershell should work on these commands. 

powercfg –h off
shutdown /s /f /t 0

Boot the computer. See if Windows now detects your USB.


Edited by JohnC_21, 27 January 2018 - 12:42 PM.


#7 ChrisHateley1982

ChrisHateley1982
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 27 January 2018 - 01:35 PM

Sorted! Thank you so much. For a while there I was worried I was never going to be able to access any of my saved files on my laptop again.

For some reason, still can't play some MKV and MP4 files on my TV though, even though my new USB is using the same file system that my 16gb's have and the files were copied to both sticks from the exact same backup.

 

Even more bizarrely, some of the ones that wouldn't work before I formatted are now playable, whereas others still aren't. 

 

Is there a way to fix that?



#8 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:24 AM

Posted 27 January 2018 - 01:55 PM

What are you using to play the MKV and MP4 files?



#9 ChrisHateley1982

ChrisHateley1982
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 27 January 2018 - 02:19 PM

Not sure. I just plug it into my TV and use the built in media player. Model is a Panasonic TX-42A400B, but can't seem to find specs on the media player.

Whatever it is I'm not sure that would be the issue as I'm essentially playing the exact same file via the exact same file system (Fat32), just a different USB with a much greater storage capacity.



#10 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:24 AM

Posted 27 January 2018 - 02:26 PM

Okay, I misunderstood. I thought perhaps you played the MKV and MP4s on the computer connected to the TV using a HDMI cable. Are you saying to have a USB flash drive connected directly to the TV and the TV has a built in media player? If that is the case the only reason I can think of that some do not play is because either the file itself was somehow corrupted or the TV's media player does not have the correct codec.



#11 ChrisHateley1982

ChrisHateley1982
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 27 January 2018 - 03:06 PM

Correct; TV has a USB port and it's plugged straight into there. 

 

I don't think it's the codec as I've tried playing unsupported files before and it gives a "codec not supported" message when I hit play. This doesn't even give me a message, just a big black box with an exclamation mark in it in place of the thumbnail image, so I guess the files are corrupting somewhere along the line.

 

Odd that it only seems to be a problem on the bigger USBs I've recently bought; a 64gb and a 2tb. Never had this problem with any of the three 16gb's I own. Also seems to happen regardless of which device I'm moving the files from; my PC, laptop or other USB stick.



#12 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:24 AM

Posted 27 January 2018 - 03:20 PM

Perhaps the TV has issues with drives larger than 32GB. FAT32 can be formatted to a capacity larger than 32GB but only by using programs like Partition Wizard or Easeus Partition Master. Windows can only format drives using FAT32 to 32GB but can read FAT32 disks with a capacity larger than 32GB without a problem as you already know. So, it could be the file itself or the TV trying to read a USB larger than 32GB. 

 

What happens when you copy the file that does not play to a 16GB flash drive. Does it play? If not then I would say the file somehow became corrupted when they were copied from the 16GB drive to the 64GB drive.



#13 ChrisHateley1982

ChrisHateley1982
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 27 January 2018 - 05:28 PM

Yeah, they still don't play if I move them back to the 16gb. I already formatted to fat32 using EaseUS, as it was originally exfat and my TV wouldn't recognise it at all.

Also just had another go at moving a file from backup to the 16gb and then from there to the 2tb. As expected it played fine on the 16gb, but not on the 2tb. And that was on my laptop so I guess the problem is the stick, not the TV. Just frustrating it only happens with certain files.

 

Oh well, no biggy. I guess I'll just have to stick to multiple 16's to store all my vids on. Thanks again for all your help. 



#14 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:24 AM

Posted 27 January 2018 - 05:41 PM

Is the 2TB formatted as FAT32 or NTFS?



#15 ChrisHateley1982

ChrisHateley1982
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 28 January 2018 - 06:35 AM

Fat32. I did format it to NTFS when I first got it to make my TV recognise it, but still had unplayable files and when I realised my 16's were Fat32, I thought it may help to make it the same. It didn't.


Edited by ChrisHateley1982, 28 January 2018 - 06:37 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users