Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Turn Off Device Maintenance Notifications


  • Please log in to reply
10 replies to this topic

#1 wdrbbq

wdrbbq

  • Members
  • 306 posts
  • OFFLINE
  •  
  • Local time:07:21 PM

Posted 26 January 2018 - 03:32 PM

Hi. I've got a Galaxy J7. Device Maintenance notifies me every time it puts an app to sleep. Is there a way to let it do what it does behind the scenes and not notify me of its every move? Thanks. 



BC AdBot (Login to Remove)

 


#2 C0bra

C0bra

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:08:21 PM

Posted 29 January 2018 - 08:23 AM

Hey there, you're not the only one this is happening to! This should fix your issue...

 

Settings>Device Maintenance>(Tap the Battery Icon on the bottom left)>(3 Dots on the top right corner)>Advanced Settings>Notification Settings

 

Then disable "Battery-draining apps"

 

Hope that helps!


Edited by C0bra, 29 January 2018 - 08:25 AM.

nIDwkQT.gif

       | IT Service Technician | A+ | Network+ | Gamer | iPhone Expert |


#3 wdrbbq

wdrbbq
  • Topic Starter

  • Members
  • 306 posts
  • OFFLINE
  •  
  • Local time:07:21 PM

Posted 29 January 2018 - 09:51 AM

Thanks. I just followed your instructions. Hopefully now,  it will simply run in the background and not tell me its every move. We'll see. Thanks again. 



#4 C0bra

C0bra

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:08:21 PM

Posted 29 January 2018 - 12:11 PM

Thanks. I just followed your instructions. Hopefully now,  it will simply run in the background and not tell me its every move. We'll see. Thanks again. 

 

My pleasure! Let me know if it works for you!


nIDwkQT.gif

       | IT Service Technician | A+ | Network+ | Gamer | iPhone Expert |


#5 wdrbbq

wdrbbq
  • Topic Starter

  • Members
  • 306 posts
  • OFFLINE
  •  
  • Local time:07:21 PM

Posted 29 January 2018 - 01:40 PM

I certainly will. It may be a day or two before I'll know for sure. Thanks again. 



#6 wdrbbq

wdrbbq
  • Topic Starter

  • Members
  • 306 posts
  • OFFLINE
  •  
  • Local time:07:21 PM

Posted 01 February 2018 - 09:58 AM

I'm back as promised. I wanted to wait until I was absolutely sure. I've gotten no notifications regarding Device Maintenance since following your instructions back on January 29th. Problem solved. Thanks again.  



#7 C0bra

C0bra

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:08:21 PM

Posted 01 February 2018 - 10:08 AM

I'm back as promised. I wanted to wait until I was absolutely sure. I've gotten no notifications regarding Device Maintenance since following your instructions back on January 29th. Problem solved. Thanks again.  

 

My pleasure! Glad it worked!


nIDwkQT.gif

       | IT Service Technician | A+ | Network+ | Gamer | iPhone Expert |


#8 vesna2525

vesna2525

  • Members
  • 3 posts
  • OFFLINE
  •  

Posted 02 July 2018 - 12:13 PM

Hey there, you're not the only one this is happening to! This should fix your issue...
 
Settings>Device Maintenance>(Tap the Battery Icon on the bottom left)>(3 Dots on the top right corner)>Advanced Settings>Notification Settings
 
Then disable "Battery-draining apps"
 
Hope that helps!



#9 vesna2525

vesna2525

  • Members
  • 3 posts
  • OFFLINE
  •  

Posted 02 July 2018 - 12:18 PM

i have samsung SM-J510FN.how to turn offdevice maintenance.i tryed evrithing and nothing pls help me

#10 vesna2525

vesna2525

  • Members
  • 3 posts
  • OFFLINE
  •  

Posted 02 July 2018 - 12:20 PM

Not helping me with that i have tried

#11 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,976 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:07:21 PM

Posted 02 July 2018 - 12:55 PM

One cannot, to my knowledge, actually turn off device maintenance and it would be foolish to do so even if one could.

 

One can control what messages one receives to one extent or another.  In the case of my Galaxy S7 the prior instructions do not work because the option presented is not present.  If, however, I go in to Device Maintenance and look under the Battery category I can choose what level of power saving mode I want and, further down the page, choose what apps I wish to have unmonitored and which apps I wish to always sleep very shortly after I complete using them.   I have set my third party launcher, Evie, to be unmonitored along with a couple of others that need to be running in the background constantly so that they can monitor the date and time and take actions at specific ones.

 

One can also tweak Performance Mode (High performance being one of the options, with "Optimized" being the default).

 

Device maintenance is part and parcel of the Android operating system and a very valuable one at that.  It should be configured, not turned off.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users