Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

multicore/multithread intel core i7 8550u Kaby Lake U/Y


  • Please log in to reply
9 replies to this topic

#1 fueledbydrprper

fueledbydrprper

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:05 AM

Posted 22 January 2018 - 10:40 AM

specs pertinent to this post:

Dell Inspiron 17 5770 laptop

Windows 10 pro x64

Intel i7-8th gen 8550u Kaby Lake U/Y (up tp 4.0 Ghz Turbo Boost)

 

BIOS settings of interest:

>performace>multicore support>ALL
>hyperthread control>ENABLED
>power management>enable (Intel shift speed technology) ENABLED

 

Task Manager shows only one core and one logical processor. Additionally msconfig: boot>advanced options shows only one core under processors in the drop down menu.

 

While monitoring a program installation in Task Manager, I observed that the CPU spent a great deal of time @ 100% CPU usage @ 1.99 Ghz and utilizing only one core. My research indicated that the BIOS settings provided above should have all four cores available, and Turbo Boost enabled.

 

How can I take advantage of the potential power of my processor?

 

Thanks for your replies.



BC AdBot (Login to Remove)

 


#2 C0bra

C0bra

  • Members
  • 170 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:10:05 AM

Posted 22 January 2018 - 11:07 AM

Windows 8+ started this fun thing where in task manager it only shows 1 graph for the entire CPU. There should be a list under the graph that shows the # of cores. I'm with you though and I like seeing the seperate graphs. 

 

Try this,

 

cGXrYBl.png

 

Right Click the CPU name in Task Manager and select "Change graph to..." then "Logical processors".

 

Let me know if that works for you!


Edited by C0bra, 22 January 2018 - 11:12 AM.

 | IT Service Tech | A+ Certified | Computer Gamer | iPhone Expert |

nIDwkQT.gif


#3 fueledbydrprper

fueledbydrprper
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:05 AM

Posted 22 January 2018 - 11:22 AM

CObra,

 

Thanks for your reply.

 

Prior to posting, I had attempted your suggestion. (I thought including it in the original post would be too much information for the original post.) 

 

Task Manager shows only one core and one logical processor.

is as shown in the lower right of the screen shot you included. In the menu accessed by right clicking the processor, the "logical processors" option is gray. This makes it inaccessible.

 

Thanks again.  ... any other thoughts? ...



#4 C0bra

C0bra

  • Members
  • 170 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:10:05 AM

Posted 22 January 2018 - 11:29 AM

My bad!! So it says you have 1 core and 1 logical processor? That's quite odd. When you were in msconfig you mentioned 1 processer in the drop down. Did you uncheck that box? If the box is checked off and it's set to 1 it will limit it during the boot.


Edited by hamluis, 22 January 2018 - 12:05 PM.

 | IT Service Tech | A+ Certified | Computer Gamer | iPhone Expert |

nIDwkQT.gif


#5 fueledbydrprper

fueledbydrprper
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:05 AM

Posted 22 January 2018 - 12:01 PM

CObra,

 

Thanks for the quick replies.

 

My bad!! So it says you have 1 core and 1 logical processor?

:wink: ...no problem ... That is why I tried to limit the amount of information in the first post.

 

You were spot on! I neglected to uncheck the box in msconfig before exiting. I took care of that problem and rebooted. (This is a custom build that I received only about two weeks ago, and I am still working on optimizing/customizing the new machine.)

 

The results of unchecking the box are dramatic:

1) Cold boot to desktop (including login at the lock screen) improved from 15 seconds to a little over 8 seconds.

2) Task manager displays all 8 cores (4 cores plus 4 logical).

3) Testing a resource intensive program revealed 3.8GHz processor speed, as viewed in Task Manager.

 

Do you think I could gain any speed by adding processors in msconfig>boot>advanced options? I'm pretty tempted to experiment.

 

Thanks again. I'm looking forward to your next reply.

 



#6 fueledbydrprper

fueledbydrprper
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:05 AM

Posted 22 January 2018 - 12:38 PM

continuation of previous post after experimenting ...

 

Specifying both 4 and 8 cores in msconfig yielded the following results:

1) Boot to desktop is about one second slower than the boot with one core.

2) The desktop is fully functional about two seconds slower with the additional cores utilized at boot. The issue is that recognizing my bluetooth mouse lags before becoming active. I wonder what's up with that???

 

For now I am going to revert back to a one core boot. If someone comes up with a suggestion, I am willing to try it. However, I am skeptical that I can improve on tthe under 8 second cold boot to a totally functional desktop.



#7 C0bra

C0bra

  • Members
  • 170 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:10:05 AM

Posted 22 January 2018 - 03:04 PM

You were spot on! I neglected to uncheck the box in msconfig before exiting. I took care of that problem and rebooted.

 

Excellent, I'm glad that worked!

 

I wouldn't worry too much about the boot options. It's probably good the way it is, you could mess around with the turbo settings but keep in mind you'll want to make sure the processor doesn't want to overheat. The only other option to boot that thing faster would be an SSD; if there isn't one already.

 

Good luck!


Edited by C0bra, 22 January 2018 - 03:10 PM.

 | IT Service Tech | A+ Certified | Computer Gamer | iPhone Expert |

nIDwkQT.gif


#8 fueledbydrprper

fueledbydrprper
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:05 AM

Posted 22 January 2018 - 05:30 PM

CObra,

 

There is an SSD/HDD combo on this machine. The SSD is the boot drive. The Turbo Options are the defaults, not overclocked. According to my research on my processor temperatures, I am within the safe range. However, I will probably purchase a laptop riser with cooling fans. I believe in a little protection.

 

There are some unfinished tweaks:

default save locations set to the HDD

9 apps removed

5 startup programs disabled at startup

10 services disabled

 

In my spare time I intend to compare autoruns.exe to this website's Startup Programs Database and make changes selectively. It may not help, but it certainly won't hurt to make this machine a little leaner.

 

Thanks again for your replies. Does this forum include any sort of feature to give reps or likes for good posts/replies?



#9 C0bra

C0bra

  • Members
  • 170 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:10:05 AM

Posted 22 January 2018 - 05:49 PM

Sounds like youre on the right track! Theres no rep or + options for this site, but knowing I was able to help is good enough for me!

Good luck with the rest of the build! Feel free to post in when youre done and how it turned out!

Edited by C0bra, 22 January 2018 - 05:50 PM.

 | IT Service Tech | A+ Certified | Computer Gamer | iPhone Expert |

nIDwkQT.gif


#10 fueledbydrprper

fueledbydrprper
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:05 AM

Posted 22 January 2018 - 05:55 PM

 

knowing I was able to help is good enough for me!

You did well!

 

Please consider this to be resolved.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users