Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trouble with DVD-RW Drive


  • Please log in to reply
2 replies to this topic

#1 bonczekc

bonczekc

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:23 PM

Posted 10 January 2018 - 05:25 PM

I recently received a DVD-RW drive to make up for my laptop's lack of a disc drive. I tried to install a game onto my laptop (if its any help, the game is The Lord of the Rings: The Battle for Middle Earth II). The game comes with 6 discs, 5 of which are used purely for install. I successfully installed the game, having no problems with the drive reading the discs or detecting them. However, when I go to play the game with the proper play disc inserted, my computer gives me an error that asks me to insert the correct CD-ROM and restart the game. Before the error displays I can hear the drive working as well, which makes it even more odd that I am getting an error. I have tried restarting my computer, re calibrating the disc laser, and uninstalling and installing the game again, but nothing has worked. What can I do to fix this?

 

Any help is appreciated, thank you.


Edited by bonczekc, 10 January 2018 - 05:31 PM.


BC AdBot (Login to Remove)

 


#2 Kilroy

Kilroy

  • BC Advisor
  • 3,335 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:10:23 PM

Posted 11 January 2018 - 12:04 PM

Are these original pressed disks and not copies?

 

I know that Windows 10 prevents SecureROM DRM from functioning.

 

You might try picking up a DRM free version from GOG.



#3 DavisMcCarn

DavisMcCarn

  • Members
  • 766 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:23 PM

Posted 12 January 2018 - 10:55 AM

EA had to take down their server for the game in 2010; but, here's an article with links to patches so it should work:

https://www.pcgamesn.com/the-lord-of-the-rings-the-battle-for-middle-earth-ii/bfme-hd-edition-multiplayer


Computer dinosaur, servicing PC's since 1976




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users