Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

System32 files and my Ethernet connection donít work


  • Please log in to reply
1 reply to this topic

#1 Xeloreye13

Xeloreye13

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:15 PM

Posted 10 January 2018 - 09:37 AM

Hello there ! I am typing this from my phone (its pretty uncomfortable for me), since, as the title says, the Ethernet on my desktop computer doesnt work...
Every evening, before going to bed, I disable the cable by using the control panel and re-enable it the next time I am using my PC. I do this for safety reasons since I let my PC on for a week and sometimes more (its pretty powerful, so I can allow myself to do so).
So, today, when I came home from work, my PC was on its lock screen. Nothing unusual, because it couldve restarted to update itself or my antivirus, I thought.
But then, when I tried to re-enable my Ethernet through the control panel, it said Enabling... for 2 seconds (thats normal) then Connection failed. Ive never seen this message before !

I thought that, just like many problems, this could be fixed with a reboot. Sadly, it remained the same. I discovered that the issue was deeper than I thought when I accidentally opened the Task Manager (I pinned it, so I can access it with a click). It said that Windows cannot find C:\Windows\system32\taskmgr.exe. Make sure you typed the name correcly, and then try again.

When I read this, I immediately thought about using the sfc /scannow command. The cmd prompt opened just fine, but when I tried to run it as an admin through the start menu to get elevated privileges, it said the same thing as with the Task Manager. So, now, I am kinda stuck and am out of ideas. I need to do some work on my PC pretty soon, so this is definitely problematic !

PS: The same thing seems to happen to most, if not all, system32 related files/programs.

BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:15 PM

Posted 10 January 2018 - 10:15 AM

I'm assuming you have rebooted your computer, correct? Firstly, disable fast startup in Windows 10. After disabling fast startup open a command prompt and type

shutdown /f /s /t 0

After the shutdown remove the power cord and hold the power button down for 30 seconds. Attach the power cord and boot. Is Ethernet back? Do you have access to another computer? If not, do you have any restore points for a doing a System Restore?  It may also be possible to do a reset with the option to keep your files but you would need to reinstall all your programs. You would need to backup your browser bookmarks. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users