Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

grub boot menu suddenly stopped showing; default boots to Vista


  • Please log in to reply
5 replies to this topic

#1 uberbleeper

uberbleeper

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:07:11 AM

Posted 08 January 2018 - 06:09 PM

I've read several dozen very detailed "repair grub bootloader using Linux live CD."

Either didn't (fully) apply or didn't work.

 

Problem suddenly appeared - I did not just install a new OS or anything.  Vista 64 bit & storage partitions are on one HDD.

Mint 18.1 cinnamon 64 bit is on an identical 2nd HDD.  For months, Grub2 menu appeared at boot.

Mint was at top of grub menu, then some other Mint options (Advanced, etc) & Vista was last.

It defaulted  to booting Mint.

 

"Something" happened & grub menu stopped displaying.  Though Mint is still at top of menu, it now defaults booting Vista (which works).

 

When  the Vista HDD is disconnected, the Grub menu appears as always & boots Mint in a few seconds.

But if Vista HDD is REconnected, grub menu doesn't show & boots to Vista.

 

I did the "reinstall grub from live CD" thing & then update-grub.  A lot of work due to having to mount several partitions & a Mint bug for Nvidia GPUs w/o proprietary drivers. 

It obviously replaced some files - the modified date changed on some but by no means, all the grub files.

 

** Question:  seems odd that during grub install, it showed "installing for i386-PC platform...", when I have 64 bit Mint & Vista.  Is that the way it should be?  I see the Grub folder named "i386" & all files in it have modified dates match when I installed Grub.  Lots of other grub folders / files weren't updated, so I don't know if it completed.

 

Now, I can get Mint booted, maybe I should run install-grub again from inside Mint, then update-grub??

 

I found a way to make the grub menu appear.  Hold both the Shift & Esc keys during post screen.  That shows a DOS looking boot menu.  All it shows is the 2 identical HDD's & DVD drive. 

Selecting the lower HDD actually brings up the normal Grub menu (still showing Vista), but works at booting what used to be the default Mint.

 

** All I need is details how to get Grub boot menu to display all the time & default to Mint.

I looked in the file /etc/default/grub.  Saw a post on it https://askubuntu.com/questions/148095/how-do-i-set-the-grub-timeout-and-the-grub-default-boot-entry#148097

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

The '#' in front of (my) hidden timeout (commenting the line) may explain the menu not showing, but since Mint (normal mode) is the grub menu's TOP entry, it should default to loading Mint, not Vista.  Unless another file overrides these settings.

FYI:  the entry above for GRUB_DISTRIB. is identical to mine.

 

Thanks.

 



BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 8,037 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:11 PM

Posted 09 January 2018 - 03:45 PM

Hi, it looks like you need to change the boot order of the HDDs in your computer's BIOS, which would be the "DOS looking menu" you're referring to.

Look on the screen on which the menu is displayed, for instructions on how to:

  • Change the order in which the drives are listed. What you want to do is move the HDD that contains Mint, above the HDD that contains Vista, in the list that you describe.
  • Save your changes, and exit.
Now your computer should boot to Grub, then automatically boot into Mint after 10 seconds.

EDIT: If the drive containing Vista was disconnected when you installed Grub, then after doing as I described above, you may need to update Grub from within Mint, then reboot, in order for the Grub boot menu to automatically display.

Edited by Al1000, 09 January 2018 - 03:50 PM.


#3 uberbleeper

uberbleeper
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:07:11 AM

Posted 09 January 2018 - 08:51 PM

Thanks Al1000.

Well, I came to the same conclusion - way down the road.  But unless you type that exact phrase (mentioning changing HDD boot order), not a single one of maybe 100 articles & forum posts I scanned mentioned anything about boot order.  They were all about reinstalling Grub & then updating it.

 

Here's the problem (or was) w/ both of our conclusions.

It had been working fine (as mentioned) for months, w/ the 'nix HDD plugged into a higher SATA connector #5 on the mobo than Vista HDD in SATA #0. 

For all that time - when Grub menu always displayed automatically at boot & opened Mint by default, the 'nix HDD  always came after the Vista HDD's boot order.

 

Vista HDD was always listed as sda1 - by several methods (for its boot partition), and Mint's / partition was always sdf1 - since day 1.  Yet Grub menu always appeared at startup & booted Mint by default.  Mint was always 1st in Grub's boot  menu & in /etc/default/grub, it was always "GRUB_DEFAULT=0.  Meaning, the 1st entry in the boot menu (Linux) would be the default OS.  And it was - for a long time, until it wasn't.

Linux was still listed 1st in Grub menu, after Windows suddenly started booting 1st & hiding the Grub menu.  That's why I was positive it must be "something else," cause no hardware, cable or BIOS changes for all the time that Linux booted 1st.  Definitely no Windows changes.

It never should have been 1st on Grub's menu.  That info on "Linux must have an earlier boot order than Windows for the Grub menu to display" was very hard to come by.  I didn't change anything to  make it suddenly stop booting Linux - unless pausing Grub boot menu  jolted it back to reality.

 

In this BIOS, There's no real indication of changing boot order of 2 identical hard drives, other than one listed above the other.  Their description is identical.   It doesn't show which SATA connector they're plugged in.

You could guess that the one listed above the other in the BIOS menu had an earlier boot.  I switched cables at the HDDs - it was easier.


 

 



#4 Al1000

Al1000

  • Global Moderator
  • 8,037 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:11 PM

Posted 12 January 2018 - 11:51 AM

I switched cables at the HDDs - it was easier.


Good stuff. That would have the same effect as changing the order of the drives in the BIOS boot menu..

...after Windows suddenly started booting 1st & hiding the Grub menu...


I have never heard of Grub booting Windows first by default, or hiding the menu, and still think that the computer was booting from Windows bootloader on the Vista HDD, and not from Grub on the Mint HDD. The fact that swapping the cables at the HDDs fixed the problem, confirms my suspicions. :)

Thanks for letting us know you fixed it.

#5 uberbleeper

uberbleeper
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:07:11 AM

Posted 12 January 2018 - 08:52 PM

Re: Grub booting Windows.

Either you misread or I wasn't clear. I said that suddenly, the Windows' or BIOS' bootloader suddenly began starting ahead of Grub.  Grub wasn't booting Windows (I'm fairly sure).  Though, changing some Grub values could make Grub boot Windows 1st, if someone wanted it.

 

It was when after 9 mo of "status quo" with my BIOS & Grub settings & all hard drive connections, that either the BIOS or Windows began starting its own bootloader ahead of Grub.

 

When that happened (no boot menu displayed) that bootloader appeared to take priority &  Grub menu stopped displaying.  The other bootloader was apparently set to not display & boot right to Windows.

Only when I started hitting keys during boot (shift, Esc, etc.) did the other bootloader pause.  THEN it displayed the DOS looking boot menu.  Other than that, I'd never seen it.  I never dual booted anything before on this machine.

 

No idea why after 9 mo the system suddenly decided Linux wasn't on the "first" booting HDD, so the Windows bootloader took over.

 

I never even went in BIOS all that time - there was no need.   After 9 months, some gremlin made it realize that BIOS showed the Windows HDD ahead of the Linux HDD, so then it booted directly to Windows.  Do not pass Go.  Do not collect $200.



#6 Al1000

Al1000

  • Global Moderator
  • 8,037 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:11 PM

Posted 13 January 2018 - 10:40 AM

Either you misread or I wasn't clear.


I don't think I misread, and you were quite clear.
 

...BIOS' bootloader...


It's not really a "bootloader." It just points the computer to a drive, which has a bootloader on it. The two bootloaders on your computer are on each HDD, Windows and Linux (Grub) respectively.
 

...that bootloader appeared to take priority & Grub menu stopped displaying.


Strictly speaking, the computer's BIOS prioritised the HDD containing the Windows bootloader, over the HDD containing the Linux bootloader. The Linux bootloader was therefore not being used.
 

The other bootloader was apparently set to not display & boot right to Windows.


It wouldn't matter what the other bootloader (Grub) was set to, because it wasn't being used. Only the Windows bootloader was being used.

I hope that clarifies what the problem was. I have no idea why it might have occurred either, but at least you've fixed it now. :)

Edited by Al1000, 13 January 2018 - 10:41 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users